Results 1 to 8 of 8
  1. #1

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77

    96 hurricane low end bogg (please help)

    i have a 96 hurricane it has 108 hours the pwc when it bought would run and then stall some times so i put new plugs in it and some seafoam is the gas what the polaris deal say 2 do while 2 make it short i went out a again and it died so took it home put fuel down carbs and it startied so i ve rebuilts the carbs but left that seafoam in the gas. any ways i have rebuilt carbs took the fuel shutoff valve out which was screwed but now i idles fine it has a low end bogg that comes and gos top end is fine as long as the rpms are over 3000 and sometimes there is no bog and it seem like it running fine ive also most had it has one know what is wrong with this pwc

    seafoam that was in the gas (no any more )
    reeds

    ps the plugs are never wet and are med tan
    and it always run great out of the water

    thank for looking


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    If the carbs have not been taken apart and cleaned, then that is what folks here will tell you to do.

    Do you have the service manual for your Hurricane?

  3. #3

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77

    low end bog

    the carbs were cleaned and all rebuilt do u think that seafoam screw them up again thanks for the reply

  4. #4
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    you can also have an air leak..................loose hose clamp.....................or a clogged "air" check valve........................

    or you can have air trapped in the fuel lines........................

    you have a poor fuel delivery.......................

  5. #5
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Quote Originally Posted by 1998PRO785HO View Post
    idles fine it has a low end bogg that comes and gos top end is fine as long as the rpms are over 3000 and sometimes there is no bog and it seem like it running fine ive also most had it has one know what is wrong with this pwc

    seafoam that was in the gas (no any more )
    reeds

    ps the plugs are never wet and are med tan
    and it always run great out of the water

    thank for looking
    When you say bog, do you mean it just falls completely flat and dies, or does the engine spit, blubber, and rumble until it "clears out" and then it runs fine? The two different symptoms mean entire different situations.



    Falling flat means it's lean and doesn't have enough fuel for combustion. Blubbering can mean you are fat and have too much fuel to one or more cylinders.


    Make sure you have done a complete rebuild on your carbs and that your pop-off pressures are set to factory spec. Then, set your high and low speed needles to factory settings. Once you've done this you can begin to find the source of the problem.


    Also, make sure you're getting good spark. You may want to remove the plug boots, cut 1/4" off the plug wires and thread the boots back on.


    Seafoam in the gas should not cause the problems you describe.


    KJ

  6. #6

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77

    bogg

    it will stall if u give 2 much gas but it wll start right away what is the pop valve and what does it do thanks

  7. #7
    johnsonmtz's Avatar
    Join Date
    Oct 2006
    Location
    Mt. Zion Illinois
    Posts
    1,250
    +1
    7
    Quote Originally Posted by 1998PRO785HO View Post
    it will stall if u give 2 much gas but it wll start right away what is the pop valve and what does it do thanks
    So you're saying if the engine is idling and you nail the throttle Wide Open it just goes blahhh and dies? If that is the case, then I'd say you possibly have a lean condition. For some reason you are not getting sufficient fuel to the cylinders.


    You need to pull the carbs, check the internal filters for junk, check the diaphragms for tears or warping, and make sure all passages are clear.


    The pop-off valve is actually a combination of the needle and seat where fuel enters the carb and a spring/arm that controls the amount of pressure applied to the needle to keep it in place. The pop-off pressure is a way to test this spring/arm/needle/seat system to ensure the proper force is being applied. Too little pressure will cause excess fuel to enter the carb, too much pressure will resctrict fuel flow. The specs for pop-off pressures varies by engine and year.



    The way to test this is to block off the fuel return line for each carb and then, with a pop-off testing gauge, apply air pressure to the fuel supply line. When the air pressure overcomes the force of the spring it "POPS" and the pressure drops. The max PSI achieved before the needle valve opens is your pop-off pressure.


    You should download the service manual for your ski here: http://jmfiskin.com/manuals/ This will give you detailed instructions for testing the pop-off pressure and what the OEM spec is for your specific ski. I still think you need to make a complete run through the carbs and fuel system, setting everything back to OEM. Once you've done that you can begin to safely troubleshoot your problems. Right now, if you're running that lean it's possible that you could toast one or more cylinders.


    KJ

  8. #8

    Join Date
    Jun 2008
    Location
    Winnipeg, Manitoba canada
    Posts
    77

    i am lost

    i rebuilt the carbs with new carb kits cleaned everthing it runs great aslong is it revs past 3000 i have the polaris sevice manual im now thinking it might be the stat pop off valve were would i buy that carb press tools

    the stupit part is my friend has the same pwc with the same problem im almost ready 2 give up

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 zxi1100 fuel carb issues please help
    By Hi burton in forum Kawasaki PWC Performance (2-stroke)
    Replies: 16
    Last Post: 08-13-2017, 04:57 PM
  2. 2007 Rxp low speed low rpms Issue PLEASE HELP!
    By redchev67 in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-20-2016, 02:57 PM
  3. 02 virage low injector voltage please help
    By sparky93 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-03-2015, 12:30 AM
  4. 2002 virage I low injector voltage please help
    By sparky93 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 05-17-2015, 09:20 PM
  5. Please help! 96 XP plumbing
    By JacRae in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-24-2007, 07:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •