Results 1 to 9 of 9
  1. #1

    96 slt 780 clattering/new ski owner/Help!

    I recently acquired a new ski 96 slt 780, one owner, very clean..currently working on MFD so I do not know how many hours but ski ran great all weekend! Everyone here has been a great help so far...I heard a clattering noise sounds like maybe toward back of ski, and only at idle speed can I hear this..think I read something on other thread about the splines on the shaft..Is this normal?..Does the shaft coupler need grease? Any help will be appreciated! Thanks!


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Grease her up there are two one under the plastic driveshaft cover and one just behind it where the shaft goes thru the hull.

  3. #3
    thanks, know just where to do it thanks to the manual you sent last night. good stuff!

    Noticed something else on my ski a clear hose at very back under the water pump maybe?..If looking at back of ski it would be in that back left corner under pump maybe?..excuse my ignorance.. clear hose looks like some hardened crap like dirt mud or build up sticking out end..Is this some type of filter all gummed up like on a suction line..or is it just a vent or what?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    That is the auto bilge suction line.

  5. #5
    no wonder the fuse was blown!, Thanks

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    They work off the jet pump vacuum no electrics involved.

  7. #7
    Thanks, as I stated before, excuse my ignorance

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275
    Quote Originally Posted by wjstewart View Post
    ... clear hose looks like some hardened crap like dirt mud or build up sticking out end..Is this some type of filter all gummed up like on a suction line?...
    That should be a metal mesh screen, cylinder shaped, connected to the end of the siphon bilge intake.

    If it is full of crud, clean it up. It needs to allow water flow if it is going to work properly.

    Make sure the plastic elbow in that hose is mounted up high under the seat, and the tiny breather hole in the side of the elbow is clear.

    Of course, if any of the hoses are cracked or crushed, replace them.

  9. #9
    Thanks a million, consider it done

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 SLT 780 help. Motor wont rev past 4000
    By nz253 in forum Polaris Open Discussion
    Replies: 32
    Last Post: 10-11-2015, 05:45 PM
  2. new SLT 780 owner and new PWC owner... help!
    By bobbo268 in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 10-16-2011, 09:30 PM
  3. 96 Slt Inter Spark New Parts Need Help
    By H20 SHREDDER in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-17-2008, 08:55 PM
  4. Outside of ski care! 96 slt 780
    By wjstewart in forum Polaris Open Discussion
    Replies: 4
    Last Post: 08-08-2008, 12:27 AM
  5. HELP PLEASE! 96' SLT 780 won't turn over
    By cnicholas in forum Polaris How To & FAQs
    Replies: 25
    Last Post: 06-20-2008, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •