Results 1 to 2 of 2
  1. #1

    88 js550 not getting water in factory exhaust

    just bought this thing, i rebuilt the motor .5 mm over. runs great. it has duel cooling. also the factory racing pipe and supertrrap water box. for some reason its not bleeding water out the pee hole on left aswell as not getting water to run in the exhaust. i dont want to run this thing long. water through the engine just fine. there is two inlet tubes and on suction line on the right. any help would be great.

  2. #2
    seaobin's Avatar
    Join Date
    Jun 2007
    Raleigh, North Carolina, United States
    post pics of your setup and a drawing of the water path you think you have

    Should be:

    High Pressure output of Pump to lower exhaust port. through exhaust housing into cylinder walls, out of top of head to top of exhaust chamber and out to exhaust pipe.

    Pisser should be tee-d off the line coming from the head to show you have water flowing through the block

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 12-07-2011, 05:02 PM
  2. 2003 GTX SC not getting up to Speed Or RPMs ! Help !
    By RXPBeast in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 06-11-2006, 09:32 PM
  3. Water for factory triples?
    By John in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-11-2006, 12:49 PM
  4. Jetworks mod, Can I get water from here?
    By Mongoose in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 02-15-2006, 12:47 PM
  5. More water for Intercooler/Exhaust ???
    By RXPDAVID in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-04-2005, 11:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts