Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1
    Knr's Avatar
    Join Date
    May 2005
    Location
    MISSOURI CITY! TEXAS!!
    Posts
    431

    TEXAS E.F.I SKI BREAKS LOOSE !! NO PORTING!!

    JUST GOT THE WORD

    WFO's (richard) ski just pulled a 76.6 mph no porting, on the seat,with fernandos package

    were going BALLASTIC

    way to go guys


  2. #2
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    AWSOME!!!!

    Now we need to teach that Columbian to work on RXP's

  3. #3
    Knr's Avatar
    Join Date
    May 2005
    Location
    MISSOURI CITY! TEXAS!!
    Posts
    431
    JERRY
    i bet if we had one here he would

    maybe you should move down here .

    jerry check your PM[/b]

  4. #4
    Pistonwash's Avatar
    Join Date
    Aug 2005
    Location
    Florida
    Posts
    3,595
    +1
    77
    This getting plain stupid now.

    Nando just called me speaking in an unknown tongue..have no idea what the heck he said...lmao.

    Tell Richard to post that speed on here..time for him to gloat. His un-ported goes faster than DMD's ported...amazing.

  5. #5
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Way to go

  6. #6

    1 Fast EFI 1300

    We encountered some serious pump damage on the liner and extension from the old pump loose shaft, but still decided to run the ski.

    This hull is in poor shape. and with the package the ski is glued to the water. We had to lose some of the stuff that we usually use because to get some lift and even then it was still planted, the best we got was 76.6 on the seat.

    14/23 prop @7160+7180 RPM

    We still got more speed left on the table and next week we should easily break 77 MPH and if we pull a Superman we should hit 78 MPH.

    Not bad for a non ported EFI 04 1300 engine. The goal is to hit 79-80 MPH with porting!!

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450


    I still have a stupid grin on my face...she just kept getting faster and faster with each adjustment. Also take into account it was close to 70 degrees, had a nasty cross wind, I had to deal with a low tide situation
    and in the middle of the test "zone" there was a section that had some serious chop 8-12"...kinda like going thru a rythum section at a moto-cross track at 75+

    With the help of Fercho I know we can get more speed out of her.
    If any of you guys are thinking of getting a piece of the handling/speed package...we may have a few new twists for the EFI boats.

    Call it the WFO option !!!

    trashed parts tally for the day:
    (1) pump liner
    (1) pump extension housing
    (1) 14/20 prop
    (1) damaged 04 vein section
    (1) slightly damaged 14/23 DF prop
    (1) slightly damaged NEW vein section

    All in all it was a good day!!!

  8. #8

    Join Date
    Nov 2005
    Location
    USA
    Posts
    4
    NO WAY are you getting those speeds. You're using secret parts that Fernando stole from TJ. Basically, you're lying just like the rest of the "Texas Gang".

    I'd like to see you run those kinds of speeds up north where I live. Wait a minute, that would make you faster. I'd like to see you run those speeds down south in the heat! Uhhh, wait, you are down south. Well, you just wait 'till MB2 and you'll see what I run!

  9. #9
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    Tim if thats you...you are kinda sick in the head aint ya?

  10. #10
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,398
    +1
    2,524
    No, thats not him. I just checked IP addresses

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Ski Break-in??
    By Hector_750 in forum 4-Tec Performance
    Replies: 25
    Last Post: 06-13-2008, 11:17 AM
  2. Jet ski breaks away from trailer, injures woman
    By shawn alladio in forum High Performance Watercraft Safety
    Replies: 1
    Last Post: 04-07-2008, 10:38 PM
  3. If ski breaks down, quest for ya?
    By bski224 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-20-2007, 05:43 PM
  4. wheels breaking loose. Literally
    By CAM D. in forum Videos & Pictures
    Replies: 2
    Last Post: 06-14-2007, 06:31 PM
  5. Hydros project ski breaks 82 MPH
    By Insanediego Joe in forum Yamaha PWC Performance (2-stroke)
    Replies: 66
    Last Post: 12-17-2006, 06:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •