Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 26
  1. #1
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280

    PUMP, SHOE, PROP...All Toast!!! 53Hrs!!!

    As the title says it,s all toast......I think the pump bearing wen,t and knocked onto the rest possibly even the engine!!!!!!

    Pump removed and engine turns over real slow, or could be shaft bearing also...don,t know yet til I strip it out!!!!

    Will post pics soon....


  2. #2
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by English Bob View Post
    As the title says it,s all toast......I think the pump bearing wen,t and knocked onto the rest possibly even the engine!!!!!!

    Pump removed and engine turns over real slow, or could be shaft bearing also...don,t know yet til I strip it out!!!!

    Will post pics soon....
    Sounds like bearings.

  3. #3
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280
    Ah mate you should see it!!!!! give us few mins and I,ll post some pics....Do ya know anyone with a whole pump setup for sale??

  4. #4
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by English Bob View Post
    Ah mate you should see it!!!!! give us few mins and I,ll post some pics....Do ya know anyone with a whole pump setup for sale??
    I would contact Rudy from Rrated. He may or may not have a whole pump setup. Either way, you can at least order what you need from him. Unless you have a kawi dealer on your side of the water.

  5. #5
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280
    As promised here the pics...and it looks bad.......
    Click image for larger version. 

Name:	DSC01713.JPG 
Views:	64 
Size:	74.9 KB 
ID:	87958

    Click image for larger version. 

Name:	DSC01718.JPG 
Views:	74 
Size:	115.7 KB 
ID:	87959

    Click image for larger version. 

Name:	DSC01721.JPG 
Views:	59 
Size:	76.4 KB 
ID:	87960

    Click image for larger version. 

Name:	DSC01722.JPG 
Views:	55 
Size:	73.7 KB 
ID:	87961

    Click image for larger version. 

Name:	DSC01726.JPG 
Views:	58 
Size:	76.1 KB 
ID:	87962

    This is starting to look expensive.....

  6. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,993
    +1
    455
    Quote Originally Posted by English Bob View Post
    As promised here the pics...and it looks bad.......

    This is starting to look expensive.....
    Holy Chit!!!

    Bob,
    Thats some serious failure right there. I know a member on here had a pump bearing failure and caused harm to his motor. I think he wound getting the motor rebuilt. Good luck

  7. #7
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280
    Quote Originally Posted by BluUltra250x View Post
    Holy Chit!!!

    Bob,
    Thats some serious failure right there. I know a member on here had a pump bearing failure and caused harm to his motor. I think he wound getting the motor rebuilt. Good luck
    Think I may be too late....tried to turn motor over with pump removed real slow and sounded real bad.....

  8. #8
    Dubz1's Avatar
    Join Date
    Oct 2006
    Location
    Southern California
    Posts
    2,509
    Curious. I know your across the water, but, did you have the IMPROS mod done to your pump?

  9. #9
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280
    Quote Originally Posted by Dubz1 View Post
    Curious. I know your across the water, but, did you have the IMPROS mod done to your pump?
    Nope!!!! bone stock.....here ya ain,t got a spare pump under ya work bench?????

    It was worth the question...right...??

  10. #10
    Dubz1's Avatar
    Join Date
    Oct 2006
    Location
    Southern California
    Posts
    2,509
    No, no spare pump on me man. Sorry..Hopefully someone has one. Good luck.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB pump shoe, all engine mounts, rxp hood!
    By islandboy in forum Sea Doo Classifieds
    Replies: 8
    Last Post: 10-26-2009, 11:54 AM
  2. Pump shoe mis-match w/ transom.
    By Pistonwash in forum Yamaha PWC Performance (2-stroke)
    Replies: 33
    Last Post: 01-15-2007, 12:57 PM
  3. RXP pump shoe!
    By Rendog in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-19-2006, 08:48 AM
  4. How to repair pump shoe inserts for intake grate...
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 07-18-2006, 09:31 PM
  5. will a RXP pump fit in a XPL pump shoe????
    By rapidacceleration in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-04-2006, 10:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •