Results 1 to 2 of 2
  1. #1

    Need Help on '02 Virage TXi Starting Problem

    Unit has been in storage for 3 years and only has 30 hours on it. Will start but as soon as start button is released the unit dies. I found a thread about a similar problem and they had a way to start the unit and keep it running using a fixed sequence of the 'bilge button' and the 'start' button. It works great. However, I am trying to find out what is causing the problem. Someone hinted that it might be the LR-503-1 module, but no real conclusion. The local dealer has told me the ski needs a new computer module - total cost with labor around $1500 and that I can't replace it myself due to loading program data.

    I look forward to any help any of you can provide. This is my first post, by the way. Thanks

  2. #2
    Ever fix this issue?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need help fixing 2002 Virage TX and Virage TXi
    By Grocery man in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 04-29-2013, 08:26 AM
  2. virage txi starting problem
    By charlie7733 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 10-04-2010, 12:22 PM
  3. Help with 02 virage Txi Fliped it
    By RiverRat19405 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-17-2008, 09:04 AM
  4. Need Help on 02 virage 700cc
    By jeffholloway96 in forum Polaris How To & FAQs
    Replies: 13
    Last Post: 12-19-2007, 07:48 AM
  5. 2000 Virage strange starting problem
    By bclake in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 09-08-2007, 04:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts