Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    Got my best speed yet but also have issues

    I ran 70.1 today superman in 6" chop thanks to a tip from fernando and a tip from richard(WFO).
    My issues are that my RPM's were 7360 and i couldn't get the ski to stop bouncing. My two questions are;
    What do i need to do to bring my rpm's down, a 14/20?
    Are a set of R&D trim tabs goin to solve the bouncing issue?


  2. #2
    spud's Avatar
    Join Date
    Jul 2006
    Location
    Oceanside, California
    Posts
    1,347
    +1
    2
    If your sponsons are like the older GPR's step them first. A 14/20 Dynafly would be a good starting point for an impeller. You can get it pitched from there.

    Get the R&D trim tabs later if you need them. When you decide to go all out get ahold of Fercho for the package and Carl at Island for the parts.

  3. #3
    sorry, forgot to post this, he are all of my mods.

    Freeflow
    PPK
    Riva Rideplate
    Riva Intake Grate
    Stock Sponsons Stepped
    Tach
    Power Filter
    Holes in hood and bucket

    I have also spoken to fernando about the package. I plan to buy the package just after the new year. It is on of my winter projects.

  4. #4
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    congrats Alex...I cant believe it is porposing with the sponsons stepped!

    Looks like it time for some trim tabs, you will need them if you go with the package.

    What were the temps when you turned 7360?

  5. #5
    Hydrotoys's Avatar
    Join Date
    Jul 2005
    Location
    Mesa, AZ
    Posts
    16,712
    +1
    85
    I'd look at your setup a little closer. Is your trim nozzle parallel to the 5deg nozzle while at neutral? Any parts hanging down underneath? Straightedge that rideplate yet?

    Also, if you were riding in rough water, and are coming from a three seater background, the gpr will be bouncy...until you come up with a package.

  6. #6
    All hail the Chief! fullboogie's Avatar
    Join Date
    Nov 2005
    Location
    Texas
    Posts
    3,156
    +1
    44
    Forget the trim tabs - use your stockers.

    Step your stock sponsons, and check the angle of your steering nozzle in the neutral position using the depth finder on a caliper. May need to also put a thin shim at the rear mounting points of your ride plate if none of the other stuff works.

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    Forget the trim tabs - use your stockers.
    Ditto.

  8. #8
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    they are plastic on 1300 boats

  9. #9
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,801
    +1
    450
    try a thinner washer in the front of the ride plate first

  10. #10
    Quote Originally Posted by WFO
    What were the temps when you turned 7360?
    Not exactly sure... I believe it was between 77-79.

    Quote Originally Posted by hydrotoys
    I'd look at your setup a little closer. Is your trim nozzle parallel to the 5deg nozzle while at neutral? Any parts hanging down underneath? Straightedge that rideplate yet?

    Also, if you were riding in rough water, and are coming from a three seater background, the gpr will be bouncy...until you come up with a package.
    The rideplate does have dip in the center. Forgot to mention the rideplate is also sanded smooth.

    Quote Originally Posted by fullboogie
    Forget the trim tabs - use your stockers.

    Step your stock sponsons, and check the angle of your steering nozzle in the neutral position using the depth finder on a caliper. May need to also put a thin shim at the rear mounting points of your ride plate if none of the other stuff works.
    What kind of caliper and where can i get it? I just recently moved out so i don't have access to many tools.


    Is the 14/20 the way to go to bring the rpm's down? Is it safe to keep running it with the rpm's that high or should i garage it until i resolve that issue. Also, i noticed when i was flushing the ski that the pisser on the right side did not have any water flowing out of it. It was flowing just fine when i was riding though. What do you guys think?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My Best Day Yet!
    By jetskibrian in forum PWC Fishing
    Replies: 1
    Last Post: 12-20-2012, 07:42 PM
  2. My Best Day Yet! Jet Ski Cobia Catching OBX
    By jetskibrian in forum PWC Fishing
    Replies: 1
    Last Post: 05-18-2010, 05:32 AM
  3. My best speed today - 75.2
    By RichGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 06-19-2008, 08:38 PM
  4. FINALLY got my SJ to start but no power!!!
    By severinsen in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 09-15-2006, 03:11 PM
  5. Got my IR Plugs for my RXP. Do I have to wait?
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-21-2005, 11:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •