Results 1 to 2 of 2

Thread: 97 GTX

  1. #1

    97 GTX

    I have a 97 GTX Seadoo and I'm having a problem when I take it out to the lake it will run fine until you hit about 30 mph then the rpm's go up to about 5900-6000. I had the carp's worked on two years ago and I took it into a dealer. They have had it for two days and can't seem to find out what is wrong with it. They took it to the lake and said it seemed as though it's being starved of fuel when you go faster? Does anyone have a idea of what is wrong with this?

  2. #2
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Catawba Island, Ohio
    Sounds like fuel blockage - somewhere. Unfortunately, there's no easy way to locate the problem without starting at the fuel tank, and cleaning the fuel switch, changing the fuel lines and cleaning the carbs... Ron

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. '05 RXT/GTX RR IC install question... O-ring?
    By 05Limited in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-03-2005, 09:54 AM
  2. A few pics of my almost finished 03 GTX sc
    By two2curupt in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-20-2005, 09:54 AM
  3. Can I post GTX stuff
    By two2curupt in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-14-2005, 10:54 PM
  4. adding external intercooler to 2003 gtx sc motor
    By rapidacceleration in forum 4-Tec Performance
    Replies: 12
    Last Post: 05-12-2005, 08:17 AM
  5. Break in period and Noise at 5000rpms on 05 GTX Limited
    By spc9669 in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 11:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts