Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18

Thread: Lower RPM'S

  1. #1

    Lower RPM'S

    I installed a 14/19r impeller with the riva wedge and grate on a 05 RXP I ran about the same RPM as stock 7850 and only 1.5-2mph faster I also installed 4"front intake I don't know where I lost the RPM's I have had the metal washer installed and replaced the wear ring I used to get 8100 on a usual bases I have not seen that in a long time. I don't know what to do I think I should be able to get a least 8000-8100 if I was able to before and should be able to hit 70-71mph.


  2. #2

    Join Date
    Jul 2008
    Location
    Aurora Ontario Canada
    Posts
    360
    +1
    6
    Quote Originally Posted by bulldog View Post
    I installed a 14/19r impeller with the riva wedge and grate on a 05 RXP I ran about the same RPM as stock 7850 and only 1.5-2mph faster I also installed 4"front intake I don't know where I lost the RPM's I have had the metal washer installed and replaced the wear ring I used to get 8100 on a usual bases I have not seen that in a long time. I don't know what to do I think I should be able to get a least 8000-8100 if I was able to before and should be able to hit 70-71mph.

    SC clutch slipping maybe?

  3. #3
    Focker Foggy's Avatar
    Join Date
    Oct 2007
    Location
    Olathe KS
    Posts
    672
    What is your weather...
    IF you are in dead summer heat, you will lose 200rpms or so
    Also, make sure your oil is clean and at proper level.

  4. #4

    Lower RPM's

    I have checked the oil it looks clean but I am unsure of checking the level I know it is to be in the middle of the bends of the dipstick but when do you check. If I let it iddle in the water on trailer it shows it's fine but if I run it for awhile check it on shore right after then it shows high.

  5. #5
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    When you check the oil the level, the ski must be level (either on the water on on the trailer), you need to warm the engine, then idle the engine for 30 seconds, then turn off the engine and wait another 30 seconds. Then check the oil... Ron

  6. #6
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    I assume you installed the 14/19 at the same time as the wear ring. If so and your old wear ring was in bad shape youwere probably losing your rpms from that. Now you have a new wear ring with a 14/19 and the prop is bringing your rpms down. 14/19 is too much prop for stock ski. You need to add boost via green wheel or something comparable.

  7. #7
    Quote Originally Posted by King_Of_Fun View Post
    When you check the oil the level, the ski must be level (either on the water on on the trailer), you need to warm the engine, then idle the engine for 30 seconds, then turn off the engine and wait another 30 seconds. Then check the oil... Ron
    I started it on the trailer the other day let it run for a few minutes then let it sit the 30 seconds the level seemed ok I ran it for about 5 min let idle then checked after 30 seconds and it seemed a little high?

  8. #8
    Quote Originally Posted by speedskixp View Post
    I assume you installed the 14/19 at the same time as the wear ring. If so and your old wear ring was in bad shape youwere probably losing your rpms from that. Now you have a new wear ring with a 14/19 and the prop is bringing your rpms down. 14/19 is too much prop for stock ski. You need to add boost via green wheel or something comparable.
    I did replace at the same time so I don't know if my RPM's came back before I did the other mods. So do you think the stage 1 needs the green wheel because I pretty much put in a stage 1 kit -the power filter but I did do the 4" intake.

  9. #9
    I think you are overpropped with 14/19 and stock SC. I matched RPM with stock on my RXT using 14/19 only when I added greenwheel and riva 3" front intake.

  10. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    If oil is good then i say your over proped for the heat and your ski. The 14/19 is a much better prop then the stocker so take out 2 mm of traileredge and see what your rpms look like.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Lower rpms
    By monaroman76 in forum 4-Tec Performance
    Replies: 8
    Last Post: 09-13-2009, 06:57 AM
  2. Break in period - auto lowered rpm's?
    By BlackJack1 in forum 4-Tec Performance
    Replies: 16
    Last Post: 07-10-2008, 03:38 PM
  3. Lower RPMs?
    By hedghog in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-15-2007, 12:22 AM
  4. Lower RPM's on one engine
    By somefun in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-19-2006, 10:24 AM
  5. Lower RPMs?
    By North49 in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-27-2005, 05:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •