Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 32
  1. #1

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27

    Angry *SOS* New GP1200R Owner - Won't rev past 4000RPM

    Just bought this Yamaha and took it to the lake and it feels kind of choked up and won't rev past 4000RPM. It also didn't move much when it did hit the most RPM. On land it revs up but still you can tell its not accelerating up very fast.

    I have been reading about inherent issues with the cat so I removed the stinger with instructions online and the cat was in one piece. I also installed Waveeater clips and did a compression check which showed 115-116PSI on all 3 cyl.

    The engine does sounds nice and has no unusual sound at all. The motor sounds very good as it idles! I also cut the zip ties that crush the oil and fuel lines to allow space for the lines to move when they shrink. I have heard this is the cause of oil lines come off which has not happend on my GPR. The ski has 73 hours and it was a one owner that is still in very new condition. It was well looked after and never in salt.


    What are some things that would cause this? Thank you for any help from you gurus!

    Best Regards,
    George


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    George Welcome to the hulk..

    Does the PV motor cycle when you hit the start button?

    Have the carbs been cleaned?

  3. #3

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27
    Quote Originally Posted by beerdart View Post
    George Welcome to the hulk..

    Does the PV motor cycle when you hit the start button?

    Have the carbs been cleaned?
    Thanks, a lot of great information on the site! I did a lot of search reading and learned quite a bit about my GRP.


    Yes, the PV motor does cycle and moves freely with no binding.

    About the carbs I don't know if they were cleaned before me but if you need to remove them to be cleaned I can say they have never been removed with no doubt. A service was performed so I did noticed new spark plugs. The previous owner I believe mention it was last used last year. He did also tell me he uses stable fuel additive when he stores it and gave me a bottle of the stuff.

    Do you think that the carb jets might be cloged on the high speed side or this issue is carb related?
    Last edited by superjetpilot; 08-14-2008 at 12:35 PM.

  4. #4
    Banned User
    Join Date
    Jul 2008
    Posts
    178
    The 4000rpm range can be a direct hint toward the PV's... you should check that they are working correctly and make sure you didnt accidently do something when installing the waveater couplers. Also.. does the ski bog out and stay at 4000rpm? how is the motor running when you are at 4000rpms?

    If you nail the throtle from a stand still how does it run?

  5. #5
    Banned User
    Join Date
    Jul 2008
    Posts
    178
    If the pv motor is running good, then you need to address your fuel flow issue/carburetors.

    The accelerator pumps on these ski's tend to get clogged a lot, and your jets might need to be cleaned. If you have some mechanical abilities you could easily rebuild your carbs. The kits are only 50$ per carb and come with everything you could need.

  6. #6
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Time to pull and clean/rebuild the carbs.

  7. #7

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27
    Quote Originally Posted by Coveted View Post
    The 4000rpm range can be a direct hint toward the PV's... you should check that they are working correctly and make sure you didnt accidently do something when installing the waveater couplers. Also.. does the ski bog out and stay at 4000rpm? how is the motor running when you are at 4000rpms?

    If you nail the throtle from a stand still how does it run?
    Yes the PVs are working correctly and I have yet installed the couplers just the clips so far.

    Yes it bogs out and you see a lot of smoke and it stays at 4000 or a bit more if you hit the throtle all the way. It feels like its just choked off. You would think it was like a bad clogage in the exhaust but thats not the case. It is as if something is badly restricing from going more!


    Thanks,
    George

  8. #8
    Banned User
    Join Date
    Jul 2008
    Posts
    178
    What kind of oil are you running? it seems that you are running to rich.. but if hte carbs were never touched then your settings should be fine... But from what you just said you definetly need to pull off those carbs and get them cleaned out or atleast inspect them.

  9. #9

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27
    Quote Originally Posted by Coveted View Post
    What kind of oil are you running? it seems that you are running to rich.. but if hte carbs were never touched then your settings should be fine... But from what you just said you definetly need to pull off those carbs and get them cleaned out or atleast inspect them.

    Haha guys is there an easy of cleaning them on the PWC? Do they get clogged due to them sitting maybe?

    Im not sure I can do the rebuild, it looks like there are a lot of little parts. Anyone know a good place to have them done for a fair price? The carbs do look almost new but I guess if its cloged then what can you do?

  10. #10

    Join Date
    Feb 2008
    Location
    Los Angeles Area
    Posts
    480
    +1
    27
    Quote Originally Posted by Coveted View Post
    What kind of oil are you running? it seems that you are running to rich.. but if hte carbs were never touched then your settings should be fine... But from what you just said you definetly need to pull off those carbs and get them cleaned out or atleast inspect them.

    Oh it was running the recommended Yamaha Lube that sticker near the oil cab tells you to use. I will stop using that and go to redline synthetic once the cat is removed.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. msx150 won`t rev past 3400rpm
    By hotx19 in forum MSX/Matrix
    Replies: 30
    Last Post: 09-04-2011, 09:35 PM
  2. 96 sltx won't rev past 5600rpm
    By raiderman444 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 07-09-2009, 11:46 PM
  3. Challenger 1800 Won't Rev Past 3500rpm
    By duramaxxed in forum Sea Doo Sport Boats
    Replies: 3
    Last Post: 07-05-2008, 08:36 AM
  4. WaveRaider won't rev past 3000 RPM ?
    By Jolly Roger in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 06-20-2008, 02:01 PM
  5. New GP1200R owner...help
    By RHeller1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 06-18-2008, 11:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •