Results 1 to 6 of 6
  1. #1
    Aviator
    Join Date
    Apr 2008
    Location
    Indiana
    Posts
    15

    Unhappy ski trys to start when lanyard is engaged without pressing the start button

    I turned my ski off the other day and it started right back up without hitting the start button. and ever since then when i stick the landyard in it wants to start. As long as the landyard is in it will try to start. Has this happend to anyone else?

    Thanks for the help in advance!!!!


  2. #2
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Sounds like the start button is shorted. Probably needs to be disassembled and cleaned. You could trouble shoot it with a volt meter if you got one.

  3. #3
    Aviator
    Join Date
    Apr 2008
    Location
    Indiana
    Posts
    15
    can you explain how to check? i have a meter but am not the best at electrical
    thanks you are always there

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    Check the wiring diagrams in the manual that should point you in the rite direction. You are most likely going to need to take the switch apart and clean it.

  5. #5
    Aviator
    Join Date
    Apr 2008
    Location
    Indiana
    Posts
    15
    Btldigger thank's alot man!!!!!!!!!!
    That was exaclty right. You are what this world needs more of. People helping People.

    Btldigger for President!!!!
    This is the Aviator and I approve this message!

  6. #6
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    LoL glad you found it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 07-22-2015, 08:40 PM
  2. 2000 kawasaki 1100 stx di load pop when trying to start
    By moose1 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 09-19-2010, 11:20 PM
  3. 2005 RXT clicks when trying to start...
    By KeithKman in forum 4-Tec Performance
    Replies: 21
    Last Post: 09-18-2009, 09:39 PM
  4. 04 Seadoo RXP Clicks when trying to start??
    By cfillingi in forum Sea Doo Open Discussion
    Replies: 65
    Last Post: 08-04-2009, 10:23 AM
  5. just a click when trying to start
    By 2kids3pets in forum Polaris Open Discussion
    Replies: 10
    Last Post: 06-29-2009, 07:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •