Results 1 to 7 of 7
  1. #1

    won't go past 20mph/4200 RPM

    1996 Polaris SL760 starts and idles fine. Checked all filters and exhaust coolant filters are fine. Do not see fuel filter? Boggs down after 20 mph on the water and 4200 RPM. Seems like rev limiter is stuck? Gas tank is full. Any suggestions or input would be greatly appreciated! Thanks, Jeff


  2. #2
    Need help??

  3. #3

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    open the electrical box and remove the grey wire from the board and see if that fixes it if so you prorably have a bad temp or oil sender . Just make sure she's not running hot .

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    What happened between the last time it ran good and the 4200 RPM's?
    Ingest any water?
    Flip the ski over?
    Is the water seperator floating or not?

    Jeff,does the MFD work?
    Is it showing low oil or fuel?
    Does the red LED flash?

    If you have no warning lamps, remove the grey limiting wire, if that still doesn't work it's probably a bad CDI?

  5. #5
    Thanks for the tip it is working great now!! Do you know if it is the low oil or high temp sensor that the grey wire goes to? That way I know what to replace!

  6. #6
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    low on fuel will also cause it........................fill her up..!

  7. #7
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    The grey limiting wire is for low fuel and oil as well as the overheat circuit. Which shows on your MFD?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 Wake Pro 215 won't go past 7000 rpm
    By Jelake in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-24-2016, 11:23 AM
  2. 2007 rxp 215 won't go past 7700 rpms and won't go past 60.
    By Eostrow1 in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-02-2016, 10:40 AM
  3. No power won't go past 6000 rpms help!!
    By tocullo in forum 4-Tec Performance
    Replies: 34
    Last Post: 03-10-2011, 03:48 PM
  4. 98 stx won't go past 8mph...rpms do increase
    By mymaries1806 in forum Kawasaki Open Discussion
    Replies: 3
    Last Post: 07-04-2009, 08:07 AM
  5. Won't go past 2750 RPM
    By immred in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-02-2007, 06:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •