Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1

    Oil light comes on

    I just sold my jet ski and the son of a bitch just keeps haunting me. She called and said that the oil low light comes on and it goes into limp mode. It happened to me everytime since I changed the oil, as soon as you take it off the trailer it will not go and it will just go in to limp mode. I just checked the oil before she left, and yes I did check it the right way. I know it is right because I put it what I sucked out which is a little over 4 quarts. It runs fine for hours but it has to warm up before the light will not come on. WTF IS GOING ON WITH THIS DAMN THING. I am not going to just leave her hanging and say well you bought it and it is your problem.


  2. #2
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    most likely a faulty pressure switch either the one under the intake manifold which measures oil pressure or the one on the front of the engine which measures blowby pressure.
    I would buy both sensors as they are not that expensive and tell her to get them fitted 1-1 1/2 hours labour max so your meeting her half way towards resolving the issue.

  3. #3
    Where is the cheapest place to get them.

  4. #4
    Crap I am an idiot I forgot to say that the light does not come on, on the trailer. I can rev it on the hose a little and it will not come on at all, put it in the water and it kicks on. But once you warm the ski up in the water it will not do it, we rode 3 hours straight and the oil light would not come on at all. You just have to idle it around till it warms up then it will be fine.

  5. #5
    captain obvious Lurker's Avatar
    Join Date
    Jul 2005
    Location
    Visalia, Ca
    Posts
    2,316
    sounds like it may be low on oil and when it warms up the oil expands bringing the level up.

  6. #6
    Is not low, I just changed it a week ago and checked it today on the hose. I did it right but I don't understand why it has to warm up or why it does not do it at all on the trailer.

  7. #7
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    in online store under oem parts finder, oil pump assy page sensor 17 is $24.50 and under engine block the sensor 31 is $22.50

    normally the ecu checks the sensor output once revs amd time go past a certain point thats why it wont do it on the trailer.
    Last edited by jasonze; 08-16-2008 at 08:55 PM.

  8. #8
    Thanks for the info, but that is weird because I ran it on the trailer for about 45 seconds and when I am in the water it is about the same time or sooner and it will do it.

  9. #9
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by super_gtx View Post
    Thanks for the info, but that is weird because I ran it on the trailer for about 45 seconds and when I am in the water it is about the same time or sooner and it will do it.

    its possible that without there being a load on the engine (running or trailer) that is has something to do with it.

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Many '03s had this problem. My '03 did too. I would get a Check Eng alarm after about 15 minutes and would come back in another 15 minutes. Both sensors were changed under warranty and fixed the problem. If you change them, IIRC, the TB needs to come off to access the sensor beneath the filter cartridge. And be careful not to loose the metal clips that hold the connectors to the sensor... Ron

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 05-08-2016, 01:50 PM
  2. Help, 2008 rxpx oil light coming on ang going into limp mode
    By Turboted in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-17-2013, 11:45 PM
  3. When exactly will the low oil light come on and go off?
    By MrBrainerd in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-17-2013, 09:39 PM
  4. oil light comes on and engine stumbles
    By DKM in forum 4-Tec Performance
    Replies: 16
    Last Post: 06-10-2010, 10:30 PM
  5. 2003 GTX SC oil light comes on but oil level is fine??
    By djbauer in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-25-2006, 04:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •