Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1

    Join Date
    Aug 2007
    Location
    wantagh ny
    Posts
    104

    06 rxp motor stalled then locked up

    i was out with a buddy of mine who has a 06 rxp w/110 hours bone stock except for the ceramic washers were changed out, and we were riding for about an hour then all of a sudden it died out on him with no warning lights or no abnormal engine sound, we tried to re start it and it and it wont turn over, starter engages but thats about it, checked shaft and impeller to see if any rope was wrapped around it, and it was clear.

    hes taking it to the dealer tommorow, just wondering what it could be,

    timing chain, dropped a valve, oil pump went out? sounds like the motor is locked up


  2. #2
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    pull the charger and see if it is locked up.

  3. #3

    Join Date
    Aug 2007
    Location
    wantagh ny
    Posts
    104
    pulled one plug and its pretty beaten up, thats as far as we go, because this ski is stock and now its the dealers problem, im thinking either dropped valve or piston let go

  4. #4

    Join Date
    Jul 2005
    Location
    euxton nr chorley lancashire, england
    Posts
    1,500
    +1
    1
    Quote Originally Posted by blu 250x View Post
    pulled one plug and its pretty beaten up, thats as far as we go, because this ski is stock and now its the dealers problem, im thinking either dropped valve or piston let go
    that is serious i hope he gets it back in time to finish his summer

  5. #5

    Join Date
    Aug 2007
    Location
    wantagh ny
    Posts
    104
    i honestly think its probably caused by the crappy service at his previous dealer (crazy freddys) when his washers went they put the same ones back in only for it to go bad again, so i told him to go to sea doo dealer who only works on sea doo and he had them fix it with metal washers at the end of the season last year. they said everything that the other dealer touched was put back wrong or screwed up somehow.

    my friend is pretty good with maintnence on his ski, and dosent abuse it either, he is now thinking of getting my ski, lol. i told him if they replace the engine it will run just as good as mine, hes so pissed off, but hey at least its covered or should be, unlike me where people who have 250x's are getting gas in oil and oil clogged intercoolers!!!(not me tho) and the kawi wont fix it

  6. #6
    Prohibido usuario
    Join Date
    Aug 2005
    Location
    Jerry's guest bedroom
    Posts
    3,469
    +1
    2
    Quote Originally Posted by blu 250x View Post
    i honestly think its probably caused by the crappy service at his previous dealer (crazy freddys) when his washers went they put the same ones back in only for it to go bad again, so i told him to go to sea doo dealer who only works on sea doo and he had them fix it with metal washers at the end of the season last year. they said everything that the other dealer touched was put back wrong or screwed up somehow.

    my friend is pretty good with maintnence on his ski, and dosent abuse it either, he is now thinking of getting my ski, lol. i told him if they replace the engine it will run just as good as mine, hes so pissed off, but hey at least its covered or should be, unlike me where people who have 250x's are getting gas in oil and oil clogged intercoolers!!!(not me tho) and the kawi wont fix it
    That explains it all. Two ceramic washer failures that ate the oil pumps up and locked the motor up due to lack of lubrication. Lucky he doesn't have a hole in the block. Easiest route is to find a used motor or SBT.

    Edit: Oh, it still has warranty? BRP will be putting a new motor in that one.

  7. #7

    Join Date
    Aug 2007
    Location
    wantagh ny
    Posts
    104
    well if the oil pump failed then i can understand that the motor siezed up and wiped out all the bearings, but since there is damage in the head due to a banged up spark plug, that would indicate something let go in most cases correct? if i recall he said that when he was at the new dealer they told him that the oil pumps were full of sh!t from the washer failure and they cleand them out.

  8. #8
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    It sounds like a valve head broke off the valve stem. This was common in the '04s & '05s. This happens more frequently when the top end is not lubed for winter storage - the stems rust and eventually breakoff... Ron

  9. #9
    and the supercharger had what to due with a broken valve? no oil press light ? it just stoped . freddys did what to the ski?
    warranty will only let you put the stock washers back in unless the cust is willing to pay for them. someone did not want to pay!! thats freddys fault? hummmm

  10. #10
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    And all the replacement washers are now metal... Ron

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2005 RXP Surged then locked up
    By turbojamie in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-14-2014, 08:04 AM
  2. anyone selling a 2006 and up rxp motor and pump set up
    By bksbigboy69 in forum Sea Doo Classifieds
    Replies: 3
    Last Post: 11-16-2010, 11:51 PM
  3. 97 xp 800 starts once then locks up!
    By LPD047 in forum 2-Stroke Performance
    Replies: 4
    Last Post: 03-06-2009, 10:41 AM
  4. Bought a 2004 RXP Locked up motor.a few ??
    By spinyard in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-15-2008, 02:17 PM
  5. Replies: 11
    Last Post: 06-18-2008, 12:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •