Results 1 to 4 of 4

Thread: Msx 140 problem

  1. #1

    Join Date
    Jun 2007
    Location
    Italia
    Posts
    14

    Msx 140 problem

    I have a problem with my msx140 for some time when heats lose benefits, goes off repeatedly, before then the engine running perfectly but after about 20 minutes of use are beginning the defect; loss of power and goes off continuously. The problem began about 4 months ago, has broken the water temperature sensor I put the pwc damaged, but at the same time began the problem in question, on the diagnosis does not go out no fault except the temperature which was repaired with Replacement of the sensor. We have also done some tests, candles, desk EMM, condenser, fuel pump but nothing to do. some help.

    [email protected]

    I'm italian scuse me for my english


  2. #2

    Join Date
    Oct 2006
    Location
    Beaver Falls, PA
    Posts
    281
    What year is the watercraft?

  3. #3

    Join Date
    Jun 2007
    Location
    Italia
    Posts
    14

  4. #4
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Location
    Campbell, Ca.
    Posts
    14,100
    +1
    105
    Have you verified the cooling route is clear?
    I know the salt water boats have some issues with blocked water passages I thought around the EMM?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Video of my msx 140 problem
    By FasterBaby in forum Polaris Open Discussion
    Replies: 96
    Last Post: 05-26-2016, 10:31 PM
  2. 2003 msx 140 problems
    By Kcindiana in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-26-2012, 06:30 PM
  3. Need Help again 2003 MSX 140 problems
    By H20Carver in forum MSX/Matrix
    Replies: 2
    Last Post: 06-13-2012, 01:59 AM
  4. 03 msx 140 problem
    By polaris.msx in forum Polaris Open Discussion
    Replies: 12
    Last Post: 07-07-2010, 05:30 PM
  5. 2003 polaris MSX 140 problem - need help
    By orrjoe in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-25-2007, 01:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •