Results 1 to 8 of 8
  1. #1

    Unhappy 2000 GP1200 Power Issue

    Hey all, just joined Green Hulk after being referred by a friend.

    My ski runs great for first 20-40 minutes and then starts to bog, feels like it's only getting 1/2 throttle. If you let off and wait a few seconds it will go full speed/throttle again for about 5 seconds and again bog out. Goes about 35mph when bogging.
    It has a brand new impeller and just had a D-plate installed. Don't think it's the carbs because the issue comes and goes? I also replaced the fuel filter.
    Any ideas?

    Thanks!


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Hey deadbeat Welcome to the hulk..

    Check the fuel tank vent. Item #15
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	GP1200R.jpg 
Views:	73 
Size:	386.0 KB 
ID:	89429  

  3. #3
    There is no VooDoo like BadVooDoo NeVerMind's Avatar
    Join Date
    Sep 2005
    Location
    Hammond, IN
    Posts
    413
    Beerdart,

    Is the bog from air getting in, or from air NOT getting in?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    If the tank is not drawing in air to replace the fuel as it is used you will create a vacuum and the flow to the pumps will suffer. A quick test is when the condition happens open the fuel fill knob and see if the condition goes away.

  5. #5
    My Jet Ski drinks more than yours Glenozzy's Avatar
    Join Date
    Apr 2008
    Location
    SML, VA
    Posts
    725
    +1
    4
    I had a "bug" once in my fuel vent. he built a nice mud home

  6. #6
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,362
    +1
    55
    opps
    Last edited by 305coco; 08-18-2008 at 03:16 PM.

  7. #7
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Quote Originally Posted by 305coco View Post
    steve my ski doesnt have that vent #15, can that be the cause why it losses power at wot

    sorry for thread hijack
    Is your tank vented at all? The GPR's only use a in vent and no out vent that is why the tank when sitting will build up pressure.(Sometimes enough to overcome the primer check valves and or the needle and seats and flood the engine with fuel if the selector switch is left on) Most brands also have a out valve the regulate how much pressure is built up in the tank when sitting in the sun.. (Around 2-3psi)

  8. #8
    305coco's Avatar
    Join Date
    May 2007
    Location
    cape coral, florida USA
    Posts
    2,362
    +1
    55
    it is there but the previous owner installed it after the filter vent assy instead of in between the tank and filter vent assy,
    but i think i may have found my problem, my primer is plumbed into my main fuel line instead of the return line

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 gp1200 not charging and low power issue.
    By chuckd1987 in forum Yamaha Old School Skis
    Replies: 2
    Last Post: 07-22-2016, 03:08 PM
  2. 2000 gp1200 starting/running issues
    By johnny p in forum Yamaha Old School Skis
    Replies: 4
    Last Post: 06-04-2012, 09:04 PM
  3. STX 12 f with power issues
    By Aquaholic in forum Kawasaki PWC Performance (4-stroke)
    Replies: 0
    Last Post: 08-06-2007, 09:15 AM
  4. 06 RXP Stage 1'd RPM & Power issues
    By mab546 in forum 4-Tec Performance
    Replies: 6
    Last Post: 07-30-2007, 07:50 PM
  5. 2000 SeaDoo XP Issue
    By mikej1033 in forum 2-Stroke Performance
    Replies: 3
    Last Post: 06-30-2007, 08:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •