Results 1 to 3 of 3
  1. #1

    Join Date
    Jul 2008
    Location
    Camarillo, CA
    Posts
    75

    Horn (alarm buzzer) not working on 04 FX HO

    Searched around but could not find much related to this...

    I am buying a 2004 FX HO from a private party. the alarm buzzer orhorn as Yamaha calls it is not functioning properly. When I unlock the craft it is clicking like the electricity is being sent but the actual beeping or buzzer sound to let me know that it is unlocked or locked is not audible.

    The previous owner thinks water may have gotten in there and shorted the horn out, any suggestions on what to look for or how to fix, where the horn wiring is located, or how much the dealer would charge to fix it.

    Thanks


  2. #2
    My question...why fix it?
    take the "remote control"throw it in a drawer and forget about.
    to many stories of ski's getting "stuck" in low mode...or batteries going dead and ski is "locked"...no thx.

    there are alot better ways of hooking up a battery disconnect and disabling the ski(for storage)...but forget about that thing out at the lake...i don't want it...

    just my opinion.

  3. #3

    Join Date
    Jul 2008
    Location
    Camarillo, CA
    Posts
    75
    any one else have an opinion on this, I still would like to have working properly.

    Am I looking at a fuse issue or wiring?

    BTW it is an 05, if it makes any difference.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Where is the measuring oil stick on 04 FX HO cruiser??
    By Waverunner4Me in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 05-28-2014, 08:15 PM
  2. Installing a boarding step on 04 FX SHO CRUISER
    By seasure1 in forum Yamaha PWC Performance (4-stroke)
    Replies: 4
    Last Post: 09-15-2007, 07:59 PM
  3. Installing a boarding step on 04 FX SHO CRUISER
    By seasure1 in forum Yamaha How To & FAQs
    Replies: 4
    Last Post: 09-15-2007, 07:59 PM
  4. Pro cdi and 780 will not work on 94 650..
    By Rodneyae in forum Polaris Open Discussion
    Replies: 25
    Last Post: 05-16-2007, 07:48 PM
  5. Anyone in MI working on 04 RXP SC's?
    By doc212121 in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-01-2007, 08:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •