Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Helicoil Question

    Stripped out my carb holes on my Rotary Valve cover. I bought a helicoil kit M8-1.0. Checked the bolt and thread size at Home Depot.

    Question is I thread the bolt in a loose helicoil and the hole is way too big. Since I have never used these before I am hoping the helicoil will reduce in size as it is threaded into the tapped hole since it is only stainless wire.

    Do you use lock tight for the helicoil as it is inserted?

    Thanks Gary


  2. #2
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    Quote Originally Posted by kocomo View Post
    Stripped out my carb holes on my Rotary Valve cover. I bought a helicoil kit M8-1.0. Checked the bolt and thread size at Home Depot. I thought these bolts were M8 x 1.25?

    Question is I thread the bolt in a loose helicoil and the hole is way too big. Since I have never used these before I am hoping the helicoil will reduce in size as it is threaded into the tapped hole since it is only stainless wire. You are correct.

    Do you use lock tight for the helicoil as it is inserted? I like to. Makes me more confident it will stay put.

    Thanks Gary

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    1,925
    +1
    66
    Bolts are 8 x1.25

  4. #4
    Crap Crap Crap. Test threaded at Home Depot into the M8-1.0 and bound up on the M8-1.25.
    Apparently that was messed up. Just did a measurement and sure enough it is M8-1.25 as stated.

    Crap Crap Crap.

    Need to order another kit.

  5. #5

    Join Date
    Jul 2007
    Location
    PDX - Oregon
    Posts
    2,205
    Quote Originally Posted by kocomo View Post
    Crap Crap Crap. Test threaded at Home Depot into the M8-1.0 and bound up on the M8-1.25.
    Apparently that was messed up. Just did a measurement and sure enough it is M8-1.25 as stated.

    Crap Crap Crap.

    Need to order another kit.
    I just did the same thing on my GSX. I went to Ace hardware, they gave me the helicoil kit as well as the speacial size tap to tap the hole for the helicoil.

    No need to loctite in place. Mine wokred like a charm, so far. I haven't taken the bolt back off since!

  6. #6
    Ziggy's Avatar
    Join Date
    Feb 2006
    Location
    NE Ohio
    Posts
    1,150
    +1
    3
    Quote Originally Posted by pdxrealtor View Post
    No need to loctite in place. Mine wokred like a charm, so far. I haven't taken the bolt back off since!
    There's where the problem occurs. Going in is easy, when removing the bolt, it's possible the coil will back out with it. I want that coil to be durn near part of the base metal.

  7. #7
    That is my plan. Cheap insurance.

  8. #8
    *&^%$*&.

    This is the first time I have used this kind of product. I need to do 4 holes in aluminum. Drilled and tapped all 4 holes with no problem. First insert went in with no problem.

    Second hole tried to cross thread and bend the tang out and damaged the threads some on the coil insertion tool. I used a die to repair the threads on the coil insertion tool and was able to install a second hole.

    I have damaged 4 more coils trying to insert them in either of the remaining 2 holes. The tap moves freely in the holes and they are clean of burrs. I have tried lubricants to help.

    Any ideas?

  9. #9
    96 xp stroked, coffmans pipe, r&d 61.8mph gps! merfturtle's Avatar
    Join Date
    Oct 2007
    Posts
    76
    Why dont you tap the holes for 1 size up bolt and forget about the helicoil. Aluminum threads pretty easy and you can use whatever size u can get, metric or standard.

  10. #10
    Would like to go with inserts since they are stainless and the aluminum stripped out so easy the first time. I am already oversized for the inserts. I don't want to have to drill the carbs to get the larger bolts through.

    If all else fails I will try to buy a used cover for rotary valve cover. Needed to step away before I through it.
    Last edited by kocomo; 09-05-2008 at 08:45 PM.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT handling question
    By MPower in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-11-2009, 10:04 AM
  2. 158 Thermostat question...
    By rx4pain in forum 4-Tec Performance
    Replies: 34
    Last Post: 11-21-2008, 10:36 PM
  3. Oil Level question , this thing mixes me up :(
    By rxp_boy in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-23-2005, 10:03 AM
  4. Question for the Hulk
    By Therock in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-20-2005, 07:13 AM
  5. RXP VTS Question
    By 1FastTrespiper in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-08-2005, 10:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •