Results 1 to 4 of 4
  1. #1

    New to the forum, need help

    Hey there one and all!
    I have a 2000 Virage TX and I get a very loud noise when the pump come out of the water for a moment (like in a tight spin) and revs up. I am thinking this is a bad bearing but have not done much work on PWCs. Any ideas? Tips for checking out where this is coming from?
    The other problem is this season it is sputtering out and then will only start up with choke. I think its a fuel filter as it seems like a fuel issue. When I look at the separator when this problem occurs there is a small amount of air at the top (maybe 3/4") and I thought the separator should be full of fuel at all times. Any thoughts?

  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Southeast Ohio
    Welcome to the Green Hulk!!

    I would pull the pump and check the bearings. It also sounds like you should go through the entire fuel system before you burn a pistion.

  3. #3
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    League City, Texas
    welcome to the forum !!!

  4. #4
    2000 pro 785 (son's) 1998 pro 785 (dads) old guy in mich's Avatar
    Join Date
    Aug 2007
    sw lower mich
    ditto fuel stuff
    noise may just be cavitation. air and water in pump= less resistance=over rev. at least you can hope

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to the forum 03 gtx sc need a lil help
    By Rotarytrader in forum 4-Tec Performance
    Replies: 3
    Last Post: 06-28-2013, 10:02 AM
  2. New to the forum Need some advice?
    By bunks in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 02-18-2012, 02:44 AM
  3. New to the Forum - need help on a MSX PPU
    By SFS in forum Polaris Open Discussion
    Replies: 1
    Last Post: 01-27-2011, 03:19 PM
  4. New to the forums... my 2000 Speedster just died :( Help?
    By Boss in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 08-03-2007, 10:24 AM
  5. New to the forums HELP!!
    By 00pro785 in forum Polaris Open Discussion
    Replies: 35
    Last Post: 05-31-2007, 09:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts