Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    dalef10ods's Avatar
    Join Date
    Sep 2007
    Location
    Plymouth England
    Posts
    294
    +1
    8

    RXP-X Misses now & then

    Can anyone help / advise please.

    I have a P-X with Riva Stage 1 + exhaust, I/C relocation, thermostat, airfilter. Usually its fine but after hard riding it misses on WOT and when pulling away. Seems to clear itself after a bit so im stumped.

    Get some salt water in the engine bay quite ofter (as i go out in surf and do lots of spins etc).



  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Have you tried putting in a new set of plugs ???

  3. #3

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    I have a similar problem, if I am interpreting your description correctly. I have the stage 1 minus the 15/22r (soon to be ordered) and reduction nozzle).
    After I ride it hard, and then letting off for a bit (20-30 seconds), if I hit it hard (WOT) my rpms only peak at 7500 but then gradually climb to 8000+. It happened to me three times within a day of riding. Symptoms are identical in each case.
    My thought is that since I do not have the stage 1 prop yet, is it possible due to the other mods I am hitting the rev limiter? Does the stock ECU back off the RPM's briefly if this occurs?

  4. #4
    ctriverguy's Avatar
    Join Date
    Aug 2007
    Location
    Ipswich, Massachusetts, United States
    Posts
    1,509
    +1
    8
    Quote Originally Posted by North49 View Post
    I have a similar problem, if I am interpreting your description correctly. I have the stage 1 minus the 15/22r (soon to be ordered) and reduction nozzle).
    After I ride it hard, and then letting off for a bit (20-30 seconds), if I hit it hard (WOT) my rpms only peak at 7500 but then gradually climb to 8000+. It happened to me three times within a day of riding. Symptoms are identical in each case.
    My thought is that since I do not have the stage 1 prop yet, is it possible due to the other mods I am hitting the rev limiter? Does the stock ECU back off the RPM's briefly if this occurs?

    On occasion I have what i call little burps or quick sputter in the throttle. only after messing around. IMO seems the hull does get a bit more water in it compared to other skis Ive owned. But also seems like TOPS is a bit more sensitive.. Not sure really what it is, but it does clear up after a few seconds.

  5. #5
    dalef10ods's Avatar
    Join Date
    Sep 2007
    Location
    Plymouth England
    Posts
    294
    +1
    8
    would it need plugs at 18 only hours?

  6. #6

    Join Date
    Jun 2005
    Location
    Hamilton, Ontario, Canada
    Posts
    556
    it shouldn't but check them. I know mine were fine.

  7. #7
    i would also recommend changing the plugs. I had the same problem on one of my skis. it didn't seem like a plug issue so i trouble shot all the connections and coils. after i saw how expensive the coils were ($100 each) i decided to change the plugs and see what happens. i was surpised to find that after changing the plugs, the damn thing ran perfect.

    you probably have a bad plug. its also cheap and easy to try out.

  8. #8
    cawky's Avatar
    Join Date
    Mar 2007
    Location
    North East England
    Posts
    281
    My dealer told me that they have a problem with plugs going off.

  9. #9
    I had a simular issue with my 07 rxp. I found a "loose" battery cable. Check that first!

  10. #10
    GTXX's Avatar
    Join Date
    Jan 2006
    Location
    NW, GA
    Posts
    1,776
    I've curious as to what sparkplug the RXP-X comes with. Anyone know?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Celebrities Now and Then
    By YoYamma in forum Open Discussion
    Replies: 0
    Last Post: 01-17-2010, 02:15 PM
  2. Replies: 8
    Last Post: 11-21-2008, 10:11 AM
  3. RXP KID is now RXP REX
    By The Bandit in forum Open Discussion
    Replies: 3
    Last Post: 02-22-2008, 03:30 PM
  4. picked up my 06 rxp today, and now have questions about break-in??
    By Brueskerxp06 in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-29-2007, 08:15 AM
  5. Neptune Pipes for the RXP in Production Now!!
    By RaceFever in forum 4-Tec Performance
    Replies: 41
    Last Post: 06-03-2006, 08:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •