Results 1 to 4 of 4
  1. #1
    y2grey's Avatar
    Join Date
    Jul 2006
    Location
    NJ
    Posts
    115

    WTB XLT 1200 gauge pod

    mine works but is kind of scratched (like some dope put a wade of keys there and went for a ride) let me know what you got.

    THIS IS A FUN PROJECT SO FAR!!!!


  2. #2
    If the only problem is that its scratched, try rubbing them out and polishing it...

  3. #3
    crashhard's Avatar
    Join Date
    Jul 2007
    Location
    Philly PA, Wildwood NJ, Indialantic FL
    Posts
    2,382
    +1
    24
    I got a screen that you couldn't even see threw back to new with alittle 600-1000 wet sand. Then hit it with a 3 inch buff.

  4. #4
    y2grey's Avatar
    Join Date
    Jul 2006
    Location
    NJ
    Posts
    115
    Thanks, I have nothing to lose
    Grey

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SOLD WTB: XLT 1200 Trim Cable, (from fulcrum to nozzle)
    By RaiderMagic in forum Yamaha Classifieds
    Replies: 0
    Last Post: 10-07-2013, 10:29 AM
  2. WTB WTB: XLT 1200 aftermarket parts
    By thetolleyman in forum Yamaha Classifieds
    Replies: 4
    Last Post: 07-05-2012, 07:14 PM
  3. WTB WTB: XLT 1200 aftermarket parts
    By thetolleyman in forum Yamaha 2 Stroke Skis
    Replies: 4
    Last Post: 07-05-2012, 07:14 PM
  4. Any way to test a XLT 1200 Gauge without it running?
    By nightrider05 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 03-02-2009, 07:30 PM
  5. WTB: XLT 1200 hull
    By zrtman in forum Yamaha Classifieds
    Replies: 7
    Last Post: 05-04-2008, 09:18 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •