Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    Banned User
    Join Date
    May 2008
    Posts
    84

    67.5 Why so slow???

    Riva Ride plate,Lx wedge,Riva Free flow and waterbox,Double bottom IC mod,Custom intake w/no filter,BOV mod,Lots of air mods
    Why is my ski only doing 1 mile more than stock????? Someone Help!!!!!!


  2. #2
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    what boost do you see on the trusty dreamometer, should be 11-12 psi.

  3. #3
    halfassjack's Avatar
    Join Date
    May 2007
    Location
    Nicholasville, Ky.
    Posts
    549
    what rpm's?

  4. #4
    Banned User
    Join Date
    May 2008
    Posts
    84
    The boost stays at Ten and sometimes in goes up a couple bars but only for a few sec. and my RPMs are right about 7900

  5. #5
    fussy1's Avatar
    Join Date
    Aug 2007
    Location
    New Zealand
    Posts
    550
    +1
    8
    Quote Originally Posted by Jrod0813 View Post
    Riva Ride plate,Lx wedge,Riva Free flow and waterbox,Double bottom IC mod,Custom intake w/no filter,BOV mod,Lots of air mods
    Why is my ski only doing 1 mile more than stock????? Someone Help!!!!!!
    Give it the timing mod. It will wake up then.

  6. #6
    ercBOOSTED's Avatar
    Join Date
    Apr 2007
    Location
    Pittsburgh, Pa
    Posts
    1,093
    +1
    3
    7900 rpm's in Miami sounds about right for what you have. Do the timing mod and you will be up to about 8050-8100 rpm's.

  7. #7
    Banned User
    Join Date
    May 2008
    Posts
    84
    New update... Went out in the water today and noticed a couple things. First of all im thinking about blocking off the BOV thats on the IC It seems to me that im loosing boost outta there even with the BOV mod.. Also I think an aftermarket Primary BOV is going to help. Also my Rpms today were not going over 7500 7600 Im pretty sure that they were around 7800 7900 Yesterday... The timming mod is in the works I should be getting my wheel in a week or two dealer was out had to order.... Thanks for you feedback guys

  8. #8
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    check your belt and hose clamps and block the bov, will be a good start.

  9. #9
    Banned User
    Join Date
    May 2008
    Posts
    84
    Blocked my BOV and tryed to put an HKS on the secoundary BOV. That didnt work had to put the factory one back. At least one of them is blocked now... Checked both belt and clamps and everything seems to be in order Ill try again on sunday and lets see what happens

  10. #10

    Smile

    Im Stock Half Tank 68.8 Gps .

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Why is my VXR so slow?
    By JonDaddy82 in forum Yamaha PWC Performance (4-stroke)
    Replies: 45
    Last Post: 08-14-2013, 08:39 PM
  2. Why So Slow...
    By RXT-260-DOO in forum 4-Tec Performance
    Replies: 23
    Last Post: 07-17-2011, 03:30 PM
  3. Why is this GTX SC so slow?
    By Shibby1485 in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-24-2007, 08:41 PM
  4. Why are the 06 RXP's so slow?
    By JD 1 in forum 4-Tec Performance
    Replies: 129
    Last Post: 10-15-2006, 09:57 AM
  5. Help! Why am I so slow?
    By GPR FL in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-05-2006, 07:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •