Results 1 to 9 of 9
  1. #1
    nau's Avatar
    Join Date
    Aug 2008
    Location
    Almaty, Kazakhstan
    Posts
    41

    Need help MFD repair

    Hi everyone

    MFD on my PRO1200 has died when polarity was mixed up.
    Since i read a lot of threads about MFD i decided to repair by my self.

    I had successfully opened up the case (thanx Christian) and took the board off. I had notice that 3 IC (some chips with 8 pins) at the left of board is burned. But unfortunately i can not read whole names of this IC's. Is anyone have scheme or could help me to identify this IC's?

    here what i could read (from the right to left): 4151, then xxxL05C, then 51L1xx

    i attached an picture of my board

    Thanks in advance
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mfd.jpg 
Views:	84 
Size:	486.1 KB 
ID:	90476  
    Last edited by nau; 08-24-2008 at 10:01 PM.


  2. #2
    I cant help you, but how did you get the mfd apart? I a cant fiqure it out.

  3. #3
    nau's Avatar
    Join Date
    Aug 2008
    Location
    Almaty, Kazakhstan
    Posts
    41
    well, i used thin hack-saw between clear plastic and black plastic. then accurate separate it using thin screwdriver
    easy but not fast

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,569
    +1
    1,272
    Quote Originally Posted by nau View Post
    well, i used thin hack-saw between clear plastic and black plastic. then accurate separate it using thin screwdriver
    easy but not fast
    There is an updated method of opening the MFD. Christian79's method works, but is delicate.

    Search for threads related to repairing the MFD.
    Have a look at post 26.

    http://www.greenhulk.net/forums/attachment.php?attachmentid=65557&d=1207193492

  5. #5
    nau's Avatar
    Join Date
    Aug 2008
    Location
    Almaty, Kazakhstan
    Posts
    41
    maybe someone have an picture an board like mine with not burned IC's?

  6. #6
    I have a open MFD from a 00 SLX 1200 laying around, i can confirm if its the same and tell you what the chips are.

  7. #7

    Join Date
    Aug 2006
    Location
    Iowa
    Posts
    1,028
    +1
    2
    I'm assuming you checked the fuse in the electrical box first? Just incase it might have just blown that.

  8. #8
    The part on the left is the Hitachi microcomputer. If those are burn marks on it and not just silicone, you're SOL, because it's a programmed part, and no on e is going to give you burn file for it even if you could find a programmer for them. The two on the right are voltage converters, one to generate a 5V from the 13.8, and one to generate the 10V. The one on the bottom is an op amp.
    I just worked on mine and got it all working except the speedo, and I'm not willing to put more time into figuring out how they generated the input to the micro from that one. I had to replace both my voltage converters, too, but I didn't have to fool with the micro, other than put a sealed reed switch on the reset to it, because it kept hanging up.
    Nice pic, btw, I had to redo a bunch of corroded runs on mine, and with a pic like that it would have been much easier.

  9. #9
    nau's Avatar
    Join Date
    Aug 2008
    Location
    Almaty, Kazakhstan
    Posts
    41
    bobinpa, thank you for detailed reply. i had missed this spot at hitachi mc, so i take the sticker off now. Seems to be this crack at mc means that i'm not able to fix it...
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	mfd_2.jpg 
Views:	192 
Size:	316.5 KB 
ID:	90929  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 2
    Last Post: 05-27-2008, 02:09 PM
  2. I need help w/ repairs in NC
    By wfhaynes in forum Yamaha Open Discussion
    Replies: 5
    Last Post: 05-01-2008, 09:22 AM
  3. Polaris 2000 Virage MFD Need Help
    By MS.SHORTY in forum Polaris How To & FAQs
    Replies: 3
    Last Post: 09-03-2007, 01:40 PM
  4. broken mfd need help fast
    By slpolaris in forum Polaris Open Discussion
    Replies: 6
    Last Post: 06-18-2007, 08:47 AM
  5. Need help, No rpm's, not charging on mfd
    By gvnitup in forum Polaris Open Discussion
    Replies: 12
    Last Post: 05-22-2007, 12:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •