Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 21
  1. #1
    jwade's Avatar
    Join Date
    May 2007
    Location
    Clarksville, Tn
    Posts
    228

    T-X - Broken Shock

    I had to start this as I just picked up a brand new front shock for another forum member.

    After riding in KY lake Saturday, I came back in and to my utter delight, my damn shock is broken...guess I wil be in contact with the dealer and get on fed-ex'ed to me.

    How many of you with either the X models or other have had this happen?

    I know I can get another one, but is there another remedy (such as a better shock available) as these stock shocks do not look like they can stand the forces of wave jumping.


  2. #2
    haleyscomet's Avatar
    Join Date
    Jun 2008
    Location
    St. Clair Shores, MI
    Posts
    212
    A couple threads started on this one so maybe do a search. I have a P-X. No problems but read that the T-X has a lot of issues with this. I'm sure some one has a fix by now.

  3. #3

    Join Date
    Apr 2008
    Location
    Miami Beach, Florida
    Posts
    81
    this happen on our 08 rxp-x and 08 rxp! suxs!

  4. #4

    Join Date
    Sep 2007
    Location
    Lexington, Ky
    Posts
    1,656
    +1
    Shock broke on my RXPX 2 days ago... well didnt break, bent the bracket, then came unhooked. So its fixable, but broken enough to be a pain in my arse...

  5. #5
    driveumhard's Avatar
    Join Date
    Feb 2007
    Location
    Cape Copral, FL
    Posts
    1,475
    +1
    4

    shock popping off

    Yep, my T-X has the same issue. Dealer fixed it but keeps popping off. Dealer ordered all new brackets & shock. Will take it in when season is over.

  6. #6
    jwade's Avatar
    Join Date
    May 2007
    Location
    Clarksville, Tn
    Posts
    228
    I looked at it pretty hard and the design is somewhat weak in my opinion. Whole assembly needs to be reinforced.

  7. #7
    Vman's Avatar
    Join Date
    Nov 2005
    Location
    NJ
    Posts
    4,363
    +1
    339
    Yeah... big problems with this; my TX is all fudged up in the hood piston department. Got to get working on a fix for it.

  8. #8
    PWC Rider & Racer RXPBeast's Avatar
    Join Date
    Feb 2006
    Location
    Essex, MD
    Posts
    194
    The whole shock on my 08 RXT-X Broke as well...

  9. #9
    gtxscrider's Avatar
    Join Date
    May 2007
    Location
    miami,fl
    Posts
    897
    It seems alot of doos have the same problem with the hood. Mine gets fixed everyonce and a while but always seems to pop off.

  10. #10
    Banned User
    Join Date
    May 2008
    Location
    Lake Havasu
    Posts
    2,924
    +1
    27
    Mines been off for over a month. Took it too the dealer after 2nd day I had it, they replaced the lower mounts, and it stayed on for awhile. Then the shock popped off. Took it to the dealer again, they popped it back on, went out for a ride, and it didn't last 10 minutes. I gave up. Waiting to see if somebody has a solution here. My brackets are lined up properly, so I don't know what to do to fix it.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Broken 2x4
    By Stretch in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 05-28-2006, 08:36 PM
  2. Help with the Hood Shock Rod thingy...
    By Shibby1485 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 05-26-2006, 12:19 PM
  3. First broken thing under warranty
    By The Green MACHINE in forum 4-Tec Performance
    Replies: 20
    Last Post: 04-10-2006, 11:33 PM
  4. another broken part!!
    By seadoo02xp in forum 4-Tec Performance
    Replies: 26
    Last Post: 02-10-2006, 06:09 PM
  5. Record broken Oct. 31??
    By ActionR32 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 10-31-2005, 11:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •