Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 28
  1. #1

    Polaris MSX 110 Wont go above 4300 RPM

    We Just recieved our MSX 110 today and took it to the lake. and we could not get the engine past 4300. It would usually sit at 4250-4300 (RPM gauge moves in 50 rpm.) I think this is some kind of electrical problem or RPM limiter. The engine operates fine between 1500 and 4300. up to about one third throttle. After that giving more throttle makes no difference at all. I dont think it is mechanical. The engine has about 10 hours on it.

    I'm also very new to this website, just signed up today. I dont know if you can reply through the site, or if I should leave my email adress. If any one knows anything about this problem please let me know. I appreciate any help I can get!

    [email protected] is my email


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Welcome to the Hulk!

    You can download the Polaris MSX 110/150 Service Manual from here.

    Do some basic tests, like checking compression.

    Are there any warning lights or messages on the NGI display?

    Can you tell us anything about the service history?
    When was it last operating properly?

    Check that the waste gate lever is moving smoothly. Search within the Polaris section on here for waste gate

  3. #3
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    My thoughts also, K447, about the waste gate.

    But there would be a warning light....

  4. #4
    we should do a compression test....

    As for service history, I have none. we baught this off of ebay, and had it shipped to our town. Can anyone post a picture of the waste gate so that I know what I'm looking for? Would this likely be the problem. If it is not moving smoothly, does it need to be replaced, or can it be lubricated?

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by Drummerdarwin View Post
    ...Can anyone post a picture of the waste gate so that I know what I'm looking for?
    Would this likely be the problem. If it is not moving smoothly, does it need to be replaced, or can it be lubricated?
    Quote Originally Posted by K447 View Post
    ...Check that the waste gate lever is moving smoothly. Search within the Polaris section on here for waste gate
    Just do the search, it is all there - look for waste gate in the Polaris section.

  6. #6
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    Quote Originally Posted by K447 View Post
    Just do the search, it is all there - look for waste gate in the Polaris section.
    Here is the arm that should move by hand (there is spring resistance from the bellows):

    Click on the picture to enlarge!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	WASTE GATE.jpg 
Views:	334 
Size:	1.50 MB 
ID:	91203  

  7. #7
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    Quote Originally Posted by Drummerdarwin View Post
    we should do a compression test....

    As for service history, I have none. we baught this off of ebay, and had it shipped to our town. Can anyone post a picture of the waste gate so that I know what I'm looking for? Would this likely be the problem. If it is not moving smoothly, does it need to be replaced, or can it be lubricated?
    Mine was 'stuck'...and I finally managed to free it. Now I apply a little lubrication before, and after, every trip.

    If you find yours sticking, I will give you the steps that worked for me.

  8. #8
    Ok I found it...I could not move it by hand...How much force does the spring apply? SHould it be very easy to move? I was trying, but at the same time I didnt want to break anything. Will I need parts to fix this, or once I can free it up can I just lubricate it?

    Thanks for youe help guys!

  9. #9
    Rocky_Road's Avatar
    Join Date
    Aug 2007
    Location
    Florida Panhandle
    Posts
    826
    Quote Originally Posted by Drummerdarwin View Post
    Ok I found it...I could not move it by hand...How much force does the spring apply? SHould it be very easy to move? I was trying, but at the same time I didnt want to break anything. Will I need parts to fix this, or once I can free it up can I just lubricate it?

    Thanks for youe help guys!
    It needs to be moveable by hand...even attached to the bellows. You can verify that it is stuck, by simply removing the 5mm allen headed bolt that attaches the bellows rod to the waste gate arm. Then take a small Vice Grip, grip the lever, and work it back and forth. Apply some Liquid Wrench where the arm enters the exhaust manifold, and keep on moving the arm. I had to cut a piece of the sewn end from my wife's favorite kitchen towel (shhh) and wrap it around the waste gate shaft, then soaked the cotton piece with Liquid Wrench, and kept the cloth soaked for several days. Without the soaked rag, the Liquid Wrench would run down the exhaust before it had the chance to do it's job (the shaft is close toleranced, and without a steady supply of penetrating fluid, could not get a complete application). The piece of rag now stays around the arm, and I soak it before every run....

  10. #10
    Ok. My dad came home and we played with it. The Waste valve does move. My dad took it for a ride without the seat on says that when he pushes the waste valve by hand the engine goes up to about 4700 RPM with throttle wide open. Without pusing it by hand it still sits at 4300 RPM. What els could be wrong? When we start the machine the check engine light flashes for 7-10 seconds, and then it goes off. It starts at the push of a button and idles very well.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Polaris msx 110 turbo-wont go above 3500 rpm
    By Sam77 in forum Polaris PWC Performance
    Replies: 13
    Last Post: 08-26-2015, 08:53 PM
  2. MSX 150 wont turn over 4300 rpm?
    By fastlane in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-22-2015, 06:41 PM
  3. MSX 150 Check engine light, wont go past 3000 rpm
    By synergy141 in forum MSX/Matrix
    Replies: 13
    Last Post: 01-29-2015, 06:18 PM
  4. 2000 Seadoo GTX DI wont go above 1450 RPMS
    By tjwj1 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 08-18-2013, 12:47 AM
  5. 2004 MSX 110 wont run over 3500 RPM?
    By krw1045 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-30-2012, 04:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •