Results 1 to 6 of 6
  1. #1
    fxho23's Avatar
    Join Date
    Aug 2008
    Location
    tampa bay
    Posts
    18

    06 ho won't start

    help, I just put a new battery in a pc625 and now when I try to start it, I just hear the bilge pump run and nothing else. It ran fine before I took it to the dealer, they said the battery was dead, so I bought a new one. Is there a code to put in, if so how? any ideas for the new guy? 2006 fx ho


  2. #2
    fxho23's Avatar
    Join Date
    Aug 2008
    Location
    tampa bay
    Posts
    18
    hmmm, sometimes when the battery is disconnected it goes into security lock mode, so you press unlock on the remote, she fired right up. credit that info to Jose at barney's in st pete, florida

  3. #3
    fx160's Avatar
    Join Date
    Nov 2005
    Location
    gold coast australia
    Posts
    2,409
    +1
    193
    Quote Originally Posted by fxho23 View Post
    hmmm, sometimes when the battery is disconnected it goes into security lock mode, so you press unlock on the remote, she fired right up. credit that info to Jose at barney's in st pete, florida
    that would've been my first guess

    kev

  4. #4
    fxho23's Avatar
    Join Date
    Aug 2008
    Location
    tampa bay
    Posts
    18
    yeah, it was just too easy. Of course I spent a lot of time checking connections electrical, fuel, taking things apart that I did not even know what they were, looking for anything that did not appear logical, just called the dealer, pressed the remote and problem solved

  5. #5
    LOOKING HYNES's Avatar
    Join Date
    Apr 2007
    Location
    Brooklyn, MD
    Posts
    740
    You still have to charge a new battery, even though yours was dead you can still charge them it doesnt mean their bad.

  6. #6
    fxho23's Avatar
    Join Date
    Aug 2008
    Location
    tampa bay
    Posts
    18
    yes I thought I had to also, but the odyessy battery pc625 was ready to go out of the box, I had them check it at the store it read 12.7, it has a 2 year warrany on it also. that's my home town baltimore.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 06 GP1300r won't start
    By whoznext in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 10-31-2015, 03:29 PM
  2. 06 GTX SC won't start-just clicks
    By Folly77 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 02-25-2011, 03:48 PM
  3. '06 RXP Sucked Rock & Won't Start
    By annweaver in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-16-2009, 09:13 AM
  4. VX 110 '06 won't start
    By davanz in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 06-18-2009, 08:11 PM
  5. Help - '06 RXP Won't Start
    By Flynfox in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-26-2008, 05:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •