Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2

    stage1 rxp can't get over 68.2?????

    ok helping a bud build his 04 rxp

    8050-8150rpm
    stock 04 RXP engine
    10lbs greenwheel
    external ic
    cold air intake
    currently soloas 14/19r 4 blade

    but we have tried a 15/20 4blade and a 15-19 3blade all with simular results

    still the best we can get is 68.2
    Last edited by rapidacceleration; 08-29-2008 at 04:39 AM.


  2. #2
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    i should mention that it feels heavy.
    I don't personally own a rxp but from the ones i have rode this RXP feels really heavy. with ALOT of wetted surface.

    to wedge or not to wedge???

  3. #3
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    What size injectors you guys running??The wedge will definatly add 1 mph...

  4. #4
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    stock 38 injectors.

  5. #5
    JFizzleJR's Avatar
    Join Date
    Aug 2005
    Location
    FL
    Posts
    8,628
    +1
    807
    That looks like a stage 2+ to me. You should increase your fueling if you have just the stock FPR and stock injectors. You should be able to turn the 15/20 with 2mm taken out. Most people with this setup get atleast 74 mph. Your results are really strange.

  6. #6
    fabrication guru rapidacceleration's Avatar
    Join Date
    May 2005
    Location
    Lake Travis austin, TX
    Posts
    1,156
    +1
    2
    strange in deed. im going to look into everything possible.

    gotta do a compression check today.
    i checked for the piggyback and its there.
    couldn't find any boost leaks.
    temps are all good.

    it pulls hard but seams to just not wanna get pass 68.
    tried my tweeked 15-20 from my RXPL and it only turned it 7600 @66.2mph

  7. #7

    Join Date
    Jul 2008
    Location
    Aurora Ontario Canada
    Posts
    360
    +1
    6
    Im thinking boost leak, and like the others said NOT enough fuel. Im running fairly close to that setup minus the greenwheel and turning 72.

  8. #8
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Quote Originally Posted by JFizzleJR View Post
    That looks like a stage 2+ to me. You should increase your fueling if you have just the stock FPR and stock injectors. You should be able to turn the 15/20 with 2mm taken out. Most people with this setup get atleast 74 mph. Your results are really strange.

    +1

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Green Wheel + External IC = 42's

    You can run that combo on a stock FPR...


    WHAT INTAKE GRATE???????

  10. #10
    Vern's Avatar
    Join Date
    May 2005
    Location
    Grand Haven, MI
    Posts
    3,594
    +1
    128
    Put 42 lb injectors in there quick ... that combo with stock injectors is usually quite lean and possibly dangerous.

    I like the wedge and it usually adds 1 mph, but you have something else going on, OR are sitting on the rev limiter. If you are pulling 8100 with a 15/20 or 15/19, the engine is pulling, but like Danny mentioned, check the bottom very carefully, the grate, the pump shoe, the pump itself. You also say it feels heavy ... it is quite possible there is a lot of water trapped between the inner and out hulls. You would have to drill a small hole through the inner hull in a spot where you could tilt the ski and make the water run back there, and see if you could suck the water out possibly. There are eight small holes under the gas tank due to the grommets to hold in the rubber mat, and more holes in the rear where other hardware attaches to the inner hull. All will allow water in between the inner/outer hull.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP ..can't get the supercharger out
    By ptscon in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 05-28-2015, 10:10 PM
  2. Can't get over 8180rpm
    By owhat in forum 4-Tec Performance
    Replies: 40
    Last Post: 03-16-2014, 02:44 PM
  3. Can I get a RXP consensus
    By seadawg in forum 4-Tec Performance
    Replies: 19
    Last Post: 09-07-2012, 02:12 AM
  4. Where can I get a SeaDoo 2008 RXP-X repair manual?
    By tempest.runner in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-01-2009, 01:25 PM
  5. Why can't i get over 70?
    By Livin on the Edge in forum Kawasaki PWC Performance (4-stroke)
    Replies: 11
    Last Post: 09-08-2008, 11:14 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •