Results 1 to 4 of 4
  1. #1
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511

    94 slt 750 help!!

    Hi. I have a 94 slt 750. Went to river 3 weeks ago and ran rough. Found hose fitting cap blown, so was taking in water. drained and fixed problem. Ran decent most of day. Pulled to re-fuel. wouldnt start. Primed w/ fuel started. Ran at about 60% for a while, 26 mph. Would not go faster. Suddenly cleared up & ran decent rest of day. That was 3 weeks ago. Was going to go to the river again and pulled it out to start it. Wouldnt start. No gas going down all 3 carbs. Will start if primed but will not pump fuel. Pulled line to fuel pump & turned over. Seems to pump. Return line is clear. Bypassed both filters. Still no joy. Red light at top of display with some strange readout comes on. I really enjoy this ski. Its fun. But seems to have alot of carb issues. It bogs and you pop the choke, & away it goes, when running. What would cause that? Mixture? Any help would be apreciated. Should I change to 3 way pump? Who has them? Thanks again.
    Last edited by rlovebk; 08-29-2008 at 03:22 PM.


  2. #2
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    the red light flashing on the display is indicating that you have a low fuel, low oil or over heating condition on your pwc.

    strange read out...........?........"LoPr".............?.....is that it...............?

    when red light flashes your boat will go into a low RPM mode protecting itself from self destruction...................................


    Ran at about 60% for a while, 26 mph. Would not go faster.

  3. #3
    Pain is fear leaving your body.... rlovebk's Avatar
    Join Date
    Aug 2008
    Location
    So. Cal.
    Posts
    5,206
    +1
    511

    thanks for the reply

    If you read further, now it doesnt run at all. no fuel going to motor. The code thing is also wack, it may be low fuel because it doesnt read a fuel level any longer.

  4. #4
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    time for carb clean out rebuilding and same with pump...............

    pump location should be at the bottom of the hull..................

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 94 SLT 750, Help point me to the correct tech references.
    By ghostinstallations in forum Polaris Open Discussion
    Replies: 12
    Last Post: 08-24-2011, 02:46 PM
  2. 94 slt 750 help with no spark please
    By power1shop2 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 10-15-2010, 02:52 PM
  3. 94 SLT 750 Help!
    By jdp8488 in forum Polaris Open Discussion
    Replies: 4
    Last Post: 06-05-2010, 02:40 PM
  4. help 94 slt 750 max 5000 rpm
    By 94polaris in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-28-2008, 10:11 PM
  5. 94 SLT 750 will not start - need help!!!!!
    By aleal in forum Polaris How To & FAQs
    Replies: 8
    Last Post: 05-24-2008, 08:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •