Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15

Thread: RUST RxpX

  1. #1
    danieletrono's Avatar
    Join Date
    Feb 2008
    Location
    San Benedetto del Tronto, Italy
    Posts
    1,550

    RUST RxpX

    Sorry just one question...this is normal with a rxpx new with 6 hours and 2 times on sea (when came back washed with water). 1 month of life.
    It is important that the rxpx isn't stay in water for a long time ,only when is the power no. No rest in water.
    How is it possible so much rust???
    Is it normal or can i ask to seadoo for this problem?
    tnx
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC03677.jpg 
Views:	82 
Size:	129.8 KB 
ID:	91667  


  2. #2
    danieletrono's Avatar
    Join Date
    Feb 2008
    Location
    San Benedetto del Tronto, Italy
    Posts
    1,550

    Nobody Can Help Me???

    Quote Originally Posted by danieletrono View Post
    Sorry just one question...this is normal with a rxpx new with 6 hours and 2 times on sea (when came back washed with water). 1 month of life.
    It is important that the rxpx isn't stay in water for a long time ,only when is the power no. No rest in water.
    How is it possible so much rust???
    Is it normal or can i ask to seadoo for this problem?
    tnx
    Nobody can help me???

  3. #3
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    That only seems to happen in salt water....coat it with WD40 or Fluid Film after each run....

  4. #4
    my 07 RXT has 48 hours on it...30 or so in the ocean, and I do have tiny specks of rust on the driveshaft but its not as much as yours and I have none on the impeller. When you spray down with freshwater do you put the hose into the pumptunnel and make sure you get alot of water in there?? Using anticorrosion spray also helps for the future..

  5. #5
    danieletrono's Avatar
    Join Date
    Feb 2008
    Location
    San Benedetto del Tronto, Italy
    Posts
    1,550
    But the shaft or the impeller are not inox? it seems simple iron if there is as much rust as here for onlr 6hours on the adriatic sea (in the mediterreanean)...
    Is impossible too much rust for as little hours... there i can't do nothing maybe....
    ????
    Inox= no rust, isn't it?(or a little bit of rust in a long period...NOT so MUCH!!!)

  6. #6
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    I would ask others near you if they are having rust problems, and if they do, what are they doing?... Ron

  7. #7
    danieletrono's Avatar
    Join Date
    Feb 2008
    Location
    San Benedetto del Tronto, Italy
    Posts
    1,550
    Maybe this is only one of my problems...

  8. #8
    i make, break, and fix things 08255's Avatar
    Join Date
    Mar 2008
    Location
    NOVA - Pohick Bay/Lake Anna
    Posts
    285
    i would spray with some crc or wd-40ish type..not completey soaked, just coated. that and a good flush should prevent any rust build-up.

  9. #9
    CRC-656 better than WD 40

  10. #10
    YoYamma's Avatar
    Join Date
    Aug 2006
    Location
    Central Florida
    Posts
    21,542
    +1
    4,761
    You're going to have to spray your equipment down with a corrosion inhibitor if you keep riding in marine...

    I usually have many of these lubricants on the shelf at any given time, I will say Bombardier makes a fantastic spray lube, better I think than anything I else I have used... this stuff destroys corrosion within minutes:
    http://www.monstermarketplace.com/Sp...ng4a16940.html

    There is another product called Salt Away too...
    http://www.saltawayproducts.com/ContactUs.htm

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007-2017 RXP/RXPX Thread of the Year
    By REID2168 in forum 4-Tec Performance
    Replies: 9425
    Last Post: 06-29-2017, 03:51 PM
  2. degreaser and rust remover?
    By BlitzK in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 07-28-2007, 03:38 PM
  3. OH NO rust damage
    By pirate33 in forum Polaris How To & FAQs
    Replies: 1
    Last Post: 04-06-2007, 01:39 PM
  4. Rust Protection! What Should I use?
    By holdnon72 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 03-27-2007, 12:10 AM
  5. how do i remove a rusted bolt?
    By mxl16 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 10-01-2005, 12:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •