Results 1 to 7 of 7

Thread: Leaks...

  1. #1

    Leaks...

    Where are all the places you guys have had leaks? I'm taking on water and can't find where it is for the life of me. Just sitting in the water the ski slowly fills up, but when I put it back on the hoist the water does not find it's way back out.

    It's not leaking around the carbon seal like it was early this year, but the seal does let a small amount of water in when you hammer the throttle. It's not coming in from the exhaust, hoses, or couplers. The water seems to be coming from under the engine. I can't tell now, but where the front bolt of the intake grate comes into the hull seems like it may be the problem. Has anyone else had this issue? Where the hell could water be coming from under the block? Maybe the hose that goes from the IC to the exhaust manifold? Just thinking out loud here. Looks like I'm done for the year and am going to have to tear this thing apart looking for every possibility of water intrusion.
    Last edited by RXP-REX; 08-31-2008 at 09:28 AM.


  2. #2
    Whats that whistling noise? jtskier11's Avatar
    Join Date
    Sep 2007
    Location
    Right side of Kansas
    Posts
    4,342
    +1
    87
    Quote Originally Posted by RXP-REX View Post
    Where are all the places you guys have had leaks? I'm taking on water and can't find where it is for the life of me. Just sitting in the water the ski slowly fills up, but when I put it back on the hoist the water does not find it's way back out.

    It's not leaking around the carbon seal like it was early this year, but the seal does let a small amount of water in when you hammer the throttle. It's not coming in from the exhaust, hoses, or couplers. The water seems to be coming from under the engine. I can't tell now, but where the front bolt of the intake grate comes into the hull seems like it may be the problem. Has anyone else had this issue? Where the hell could water be coming from under the block? Maybe the hose that goes from the IC to the exhaust manifold? Just thinking out loud here. Looks like I'm done for the year and am going to have to tear this thing apart looking for every possibility of water intrusion.
    Check the water hoses first. Clamps do break and or come loose sometimes. Then move to your intake grate bolt. Yank it out and silicone the shit out of it.

  3. #3

  4. #4
    speedskixp's Avatar
    Join Date
    Feb 2008
    Location
    venice fl.
    Posts
    8,117
    +1
    120
    Check were the pump shoe is connected to the hull. Some times they are not sealed good there.

  5. #5
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    When i installed my xs cooler i didnt silicon the bolts that go into the pump shoe after putting my bracket in i had quite a bad leak here that was un detectable. I read in a post some about filling the ski up with water and seeing where it leaked out of on the trailer. all i did was got the front of the trailer as high as possible filled the hull up to the bottom of the sc intake and looked for the water to come out. sure enuf it started leakin in the pump area. took the whole pump out and found the water comin out one of the 4 pump bolt holes. Hope this helps. R88

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    It does not sound like is your problem, but i have had the RE,s leak when not sealed good.

  7. #7
    When I put the ski in the water I checked all viewable areas for leaks and couldn't find a thing. No visible leaks coming from the back of the ski. Yet after 10min sitting in water it was noticeably getting more water in the hull. It seems to be coming from under the block. I'm going to have to pull the rear intake and SC to get a better look, too much clutter around there right now. I'm going to pull the water OUT hose going from the IC to the exhaust manifold. I wonder if maybe the engine melted or rubbed a hole in it while riding.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Leak?
    By sprchrgd89gt in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 07-12-2005, 07:17 PM
  2. 04 RXP - Leak into Hull thru VTS
    By joeg in forum 4-Tec Performance
    Replies: 7
    Last Post: 07-01-2005, 02:21 AM
  3. Rotax Racing IC - How to find leaks?
    By Jarrett in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-05-2005, 12:16 AM
  4. Does your RXP leak?
    By MikeTrin in forum Sea Doo How To & FAQs
    Replies: 15
    Last Post: 05-31-2005, 11:31 AM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •