Results 1 to 1 of 1
  1. #1

    Aloha! Have a funky engine/crab setup...maybe old Skool???

    Figured everything out

    Mahalo

    please delete
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_0083.jpg 
Views:	34 
Size:	481.9 KB 
ID:	91803   Click image for larger version. 

Name:	IMG_0084.jpg 
Views:	34 
Size:	386.8 KB 
ID:	91804   Click image for larger version. 

Name:	IMG_0085.jpg 
Views:	36 
Size:	469.8 KB 
ID:	91805   Click image for larger version. 

Name:	IMG_0086.jpg 
Views:	36 
Size:	448.7 KB 
ID:	91806   Click image for larger version. 

Name:	IMG_0087.jpg 
Views:	34 
Size:	391.6 KB 
ID:	91807  
    Last edited by Mauidave; 08-31-2008 at 04:50 PM.


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I have 2 weber engines
    By GGG in forum MSX/Matrix
    Replies: 2
    Last Post: 09-29-2010, 07:59 PM
  2. Still have an unanswered engine flush question
    By macio in forum Yamaha Old School Skis
    Replies: 9
    Last Post: 06-04-2010, 07:10 AM
  3. question on ported 1300...idle surges after having water in engine...i
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-23-2009, 09:06 AM
  4. Have your 700cc Engine rebuilt for $10.00
    By Rodneyae in forum Polaris Open Discussion
    Replies: 13
    Last Post: 04-19-2007, 07:45 PM
  5. Any 1 have a complete engine??
    By Cutter in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-11-2006, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •