Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5

    Question Help with bogging after rebuild.

    Hoping someone might have a clue for me with this bogging issue I have.

    Changed reeds to Boyesen power reeds, fuel lines and rebuilt the carbs as a result of a previous bogging issue.

    Best way to describe it is: it runs good, but when I decelerate to an idle and then try to give it the gas again, she bogs like it's starving for fuel or has a dirty filter.
    If I play the throttle up slowly and get it to higher rpm's, she screams with power and I can keep going. Even runs well at medium throttle. It's just when I take it down to idle that it is happening.

    The stock stuffers are a bit out of shape and no longer fit squarely in the cages. New ones are on the way soon I hope, but wonder if this has any effect.

    Also, since putting in the new power reeds, it seems to be running on the rich side. I lack the experience of tuning and need a tech tip or two so I don't lean it out too much. Is it bad for the engine at this point running rich as I am going for a ride tomorrow.


  2. #2

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Is your acelerator "sp" pump working ???

  3. #3
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5
    Hmmm, good call. Looking at microfiche here
    http://partsfinder.onlinemicrofiche....pe=13&A=60&B=4
    and see #15. I got rebuild kits (3) but didn't change that. I saw it, just didn't want to crack the seal on it. If that's the case, I may be out for the season here on this ski as it takes almost a month to get parts in.
    Thanks for posting.
    Quote Originally Posted by 785 lugs View Post
    Is your acelerator "sp" pump working ???

  4. #4
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5

    Question

    What about this part?
    http://www.parkeryamaha.com/index.as...D&ProdID=24324

    It states:
    Detailed Description Universal Mikuni DF52-92, 35 Liter Per Hour, This has 3 fuel outlets, 1 fuel inlet and 1 pulse inlet.
    Can also be used in place of Polaris part number 3240127.
    Note fuel pumps do not come with instructions.
    Bolt holes are 3-3/4 inch center to center.
    $26.85

    Also see:
    http://www.sbtontheweb.com/forum/arc...p/t-26193.html

  5. #5

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by SideFX View Post
    What about this part?
    http://www.parkeryamaha.com/index.as...D&ProdID=24324

    It states:
    Detailed Description Universal Mikuni DF52-92, 35 Liter Per Hour, This has 3 fuel outlets, 1 fuel inlet and 1 pulse inlet.
    Can also be used in place of Polaris part number 3240127.
    Note fuel pumps do not come with instructions.
    Bolt holes are 3-3/4 inch center to center.
    $26.85

    Also see:
    http://www.sbtontheweb.com/forum/arc...p/t-26193.html

    Thats a fuel pump yours is built into the carbs . do a search on how to prime the acelarator pump on the khien carbs or pm Casey67 he can tell you how or Randy at Watcon can send you one ASAP .

  6. #6
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5
    Noted.
    But I'm confused here, please help me understand what the accelerator pump does. I know it sounds stupid but I can't find any info on it and my mechanical mind is at a stand still of knowing what it's function is.

    This is an interesting article about pumps on 650 and 750:
    "The stock Polaris 650 and 750 pumps were inadaquate for WOT use over time. They did not pump enough volume to supply all three carbs. Most units will burn a hole through the #1 piston as a result of this."
    http://www.sbtontheweb.com/forum/showthread.php?t=16233

  7. #7

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Ok,
    I just talked to Casey he said while the ski is running take the excelerator plunger and push it all the way up with a little screwdriver or something like that and it should bleed it's self out . Also there is only one pump for each rack of carbs not three like the parts list you showed .

  8. #8

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,702
    +1
    109
    Quote Originally Posted by SideFX View Post
    Noted.
    But I'm confused here, please help me understand what the accelerator pump does. I know it sounds stupid but I can't find any info on it and my mechanical mind is at a stand still of knowing what it's function is.

    This is an interesting article about pumps on 650 and 750:
    "The stock Polaris 650 and 750 pumps were inadaquate for WOT use over time. They did not pump enough volume to supply all three carbs. Most units will burn a hole through the #1 piston as a result of this."
    http://www.sbtontheweb.com/forum/showthread.php?t=16233

    The accelarator pump gives it a squirt of fuel when you first give it the throttle until the jets kick in .so with your flame arrestor off if you squeeze the throttle you should see fuel squirt out .

  9. #9
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5
    Just heading out in a few minutes to meet up with some guys for wave jumping in the ocean here. I have another ski I can use, but wonder, will I do any damage to the SLX if the lower rpm's aren't running properly? (It's fine once the revs are up)

  10. #10
    SPEED KILLS, BUT YOU GET THERE QUICKER Keddano's Avatar
    Join Date
    Jul 2007
    Location
    Cedar Rapids,Iowa
    Posts
    6,381
    +1
    23
    A bad accelrater pump shouldn't hurt the engine.Just give you the bog.That sounds like what it is.Randy should be able to get you on sooner then that. Pirate has had to replace the one on the Virage and I think on the Matrix too today.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help..not right after rebuild
    By traderdoc in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 09-27-2009, 02:59 PM
  2. help with bogging
    By rocket1195 in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 08-16-2009, 09:55 PM
  3. Help with a Carb Rebuild?
    By rlacy916 in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 06-29-2009, 12:53 AM
  4. Help with Parts description & rebuild
    By Evo in forum Yamaha Old School Skis
    Replies: 0
    Last Post: 02-26-2008, 12:08 PM
  5. help with bogging
    By rundo's 900zxi in forum Kawasaki PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-27-2007, 08:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •