Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Red Rocker bwilso1's Avatar
    Join Date
    Jun 2007
    Location
    Folsom
    Posts
    10

    250x Sounds like supercharger is slipping

    This may not be the place to post this but here we go. I ride my ski almost every weekend and know when something doesn't sound right. This is definitely a problem but would like your input. Under Normal acceleration, just before you reach a level plane, the supercharger (That grinding sound) or cooling system kicks in and engine runs smooth and your up to speed. This would be normal conditions. In this case, ski cant get up to plane, just grinding. It happens 50% of the time and ate all remaining gas, more smoke out the back then normal. No warning or alarm lights. I had an extra person on the back but it's a three seater and wasn't over weight. Any suggestions?


  2. #2
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280
    Quote Originally Posted by bwilso1 View Post
    This may not be the place to post this but here we go. I ride my ski almost every weekend and know when something doesn't sound right. This is definitely a problem but would like your input. Under Normal acceleration, just before you reach a level plane, the supercharger (That grinding sound) or cooling system kicks in and engine runs smooth and your up to speed. This would be normal conditions. In this case, ski cant get up to plane, just grinding. It happens 50% of the time and ate all remaining gas, more smoke out the back then normal. No warning or alarm lights. I had an extra person on the back but it's a three seater and wasn't over weight. Any suggestions?
    Don,t ride it again untill ya get it checked out.......could be SC, pump bearing, or engine,....but man for ya own sake check!!!!!
    It gets bluddy expensive if ya don,t.....Good luck...

    kind regards..

  3. #3
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    Any smoke is not normal.................

  4. #4
    English Bob's Avatar
    Join Date
    Jun 2007
    Location
    Southern UK
    Posts
    280
    Quote Originally Posted by Ultra250 Tn View Post
    Any smoke is not normal.................
    Unless ya rubbin too hard..... oops, sorry....couldn,t resist...

  5. #5
    blownhotrodder's Avatar
    Join Date
    May 2007
    Location
    Buford, Ga.
    Posts
    601
    How many hours are on the ski?

  6. #6
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    I got a used s/c for sale. Let me know if you need it

  7. #7
    Red Rocker bwilso1's Avatar
    Join Date
    Jun 2007
    Location
    Folsom
    Posts
    10
    I have 150 hours. Have it in for service when it needs to go in. Stock motor. Havent touched a thing. Have the dealership do all the work and I did buy extended warrenty. I take it on long rides. 50-60 miles at a time.

  8. #8
    JET250's Avatar
    Join Date
    Jan 2008
    Location
    Australia mate fair dinkum.
    Posts
    1,278
    +1
    2
    what does it do on the trailer on the hose, sound all good rev ok. if yes, will be pump bearings, especially with those hours. its not good if they let go.

  9. #9
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,992
    +1
    455
    Redrockr,
    you changed your screen name? and wasnt your boat for sale? why the change?

  10. #10
    Red Rocker bwilso1's Avatar
    Join Date
    Jun 2007
    Location
    Folsom
    Posts
    10
    Name change because I finished personalizing the ski and trailer license plate with the name "Red Rocker". Yes I did have ski up for sale but noone called me on it, so I kept it.
    Last edited by bwilso1; 09-07-2008 at 12:07 AM. Reason: update

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 12
    Last Post: 09-08-2015, 02:36 AM
  2. Replies: 3
    Last Post: 08-11-2014, 06:50 AM
  3. supercharger is slipping at 12n.m
    By herc in forum 4-Tec Performance
    Replies: 8
    Last Post: 05-06-2010, 08:56 PM
  4. sl1050-feels like it is slipping on accel
    By chvscks319 in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 07-06-2009, 04:37 PM
  5. This is what a power pipe sounds like.
    By Green Hulk in forum Videos & Pictures
    Replies: 7
    Last Post: 11-07-2005, 11:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •