Results 1 to 8 of 8
  1. #1

    Join Date
    Nov 2007
    Location
    Olathe Kansas
    Posts
    19

    Trim Box ZXI 900

    Does anyone have a permanent fix for the trim box on a zxi 900, that keeps taking water in? I understand that they are known for this, but has anyone come up with a seal or fix?


  2. #2
    axgrider73's Avatar
    Join Date
    Feb 2007
    Location
    Southeast Ohio
    Posts
    2,059
    No, but I have always wondered if a healthy coating of grease on the full length of the cable would stop the water from coming in?

    Basically filling the void between the cable and housing.

  3. #3

    Join Date
    Nov 2007
    Location
    Olathe Kansas
    Posts
    19
    I was going to try to apply light grease to the cable on the ends then squeeze some RTV around the void in the cable,trick is keeping the RTV from sticking to the cable.

  4. #4
    Quote Originally Posted by Lineman482 View Post
    Does anyone have a permanent fix for the trim box on a zxi 900, that keeps taking water in? I understand that they are known for this, but has anyone come up with a seal or fix?
    Yes, there is a permanent fix for that.
    Order a Kawi P/N 49016-3702 which is a small rubber boot - cheap $3. Install that at the end of of the trim cable at the pump side where there is an exisit rubber boot (smaller than the new one). DO NOT remove the existing boot. The new boot has a large ID end and a small ID end. The large ID end of new boot goes over the existing boot. Zip-tie the both ends of the new boot and the problem is solved.

  5. #5

    Join Date
    Jul 2009
    Location
    Lake St. Louis
    Posts
    81
    Is there a before and after pic someone has of this fix and also is this in regards to an 1100 too?

    thank you.

  6. #6
    I saw this thread and wanted to purchase this boot for my 95' 900 zxi - when I looked up the p/n you posted I couldn't find anything... Where can I purchase it?

    Thanks,

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,011
    +1
    283
    It's used on an Ultra 150. You should be able to get it from anyone that sells parts for that.

  8. #8

    Trim boot

    Look at any oe site that sells kawa parts and you can find it under the 1998 kawa 1100zxi. Below is where I buy my parts. The kawa oe part number is 49016-3702. Costs 2.18 plus shipping. Use two zip ties to secure.

    Now, they will charge about 16.00 to ship so if it were me, I would go to a local dealer and tell them you want to order the part. It will be a lot cheaper overall. AND IT WORKS. I put it on my 1996 kawa 750zxi and my 1998 kawa 100zxi.

    If I can help you more, email me at [email protected]

    http://www.cyclepartsnation.com/page.../Kawasaki.aspx

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. How do I seal up trim box on a 750 ZXI?
    By SlurpJ in forum Kawasaki PWC Performance (2-stroke)
    Replies: 8
    Last Post: 06-06-2012, 01:33 PM
  2. Replies: 9
    Last Post: 09-14-2010, 05:43 PM
  3. WTB WTB ZXI 900 Trim Sensor and possibly module
    By chvscks319 in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 09-14-2010, 10:59 AM
  4. WTB Kaw ZXI 750 Trim Box
    By cbrf1wr in forum Kawasaki Classifieds
    Replies: 1
    Last Post: 11-28-2008, 09:17 PM
  5. '96 ZXI 900 Trim Box Removal?
    By bcgriff in forum Kawasaki Open Discussion
    Replies: 6
    Last Post: 08-05-2008, 11:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •