Results 1 to 6 of 6

Thread: SLT 780 Bogging

  1. #1

    SLT 780 Bogging

    Hey guys -

    I've been following some threads on the 780 bogging and I've had a problem for the past several seasons that hasn't been much of a problem for my buddy plrs x45 or myself, but if either of our wives drive the boat they are up in arms that it needs to be fixed!! So I figured I would stop lurking on here and get posting!!

    So here's the deal - it bogs down quite a bit and if you feather the throttle it clears up and is fine. So I'm not sure if feathering is a common term, but I mean going from no throttle to 1/8th back to no throttle to 1/6th, etc very quickly until you get to full throttle with a good running boat.

    If you do that you'll be fine for a while as long as you don't let it idle too much. If you idle for a while (like in a no-wake zone) it'll bog down and you can feather it a bit up to full throttle and then it's fine for again.

    I have noticed that if I choke it until it dies (or just short of that) I can take off and it will run just fine. This is the part I've seen mentioned more recently and is starting to worry me... I've seen replies that "if the choke improves then rebuild carbs/replace fuel lines or else you may hole a piston"...and that's the last thing I want to do.

    Any help would be appreciated!! With respect to maintenance on the boat and fuel system - haven't done too much outside of seasonal storage stuff and greasing the shaft.

    I had accidentally hijacked another thread and have since edited that post and reposted here. Apologies for that.

    Thanks,


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,276
    Sure sounds like you need to take those carbs off and apart, and clean and rebuild them.

    Not that hard to do. Use only Genuine Mikuni brand parts or rebuild kits.

    If you really don't want to do the carbs yourself, you can send them to Watcon.

  3. #3
    Plrs X45's Avatar
    Join Date
    Sep 2006
    Location
    Joliet, Il
    Posts
    357
    +1
    5
    Welcome to the boards! I hope you get that SLT up and running good. It's a great boat.

  4. #4
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5
    Have been dealing with a similar if not exact type of problem even after rebuilding the carbs and putting in Boyesen Power Reeds. Have also searched on-line for what was brought to my attantion as being an issue with the 'accelerator pump'. Problem is, it's no longer available and not to be found (yet) on ebay. However have come across this page with a replacement cover, and the symptoms they list on the page fits both our problems, I think.
    http://www.magicracing.com/Boyesen-Q...ews.html?48593

    * K447 has quite a knowledge in the Polaris department here, * so if you are reading this, can you give us an opinion if this cover can resolve the issues at hand?

    Also:
    http://www.carlscycle.com/catalog_ke...OVER&submit=Go
    Last edited by SideFX; 09-05-2008 at 06:15 PM.

  5. #5
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,276
    Quote Originally Posted by SideFX View Post
    ...K447 has quite a knowledge in the Polaris department...
    I'm probably one of the few Polaris guys who isn't into carbs.

    Other than knowing a little about basic carb rebuilding and such, I try to stay away from them.

    Ficht fuel injection, I am getting more comfortable with.

  6. #6
    SideFX's Avatar
    Join Date
    Feb 2007
    Location
    BC Interior
    Posts
    988
    +1
    5
    I pm'd Keddano with this querrie as I didn't want to rehash this topic just yet without more info. Hoping for a quick fix so I can get a few more days on the water before winterizing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 16
    Last Post: 12-29-2011, 10:09 PM
  2. SLT 780 Bogging
    By drummerman2028 in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-08-2008, 11:17 PM
  3. 96 SLT 780 questions
    By BBCaprice in forum Polaris Open Discussion
    Replies: 13
    Last Post: 05-14-2007, 10:25 AM
  4. Help, SLT 780 problem(s)
    By tcboss429 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 05-07-2007, 03:36 PM
  5. Old Friends Reunited (SLT 780)
    By Mikoo in forum Polaris How To & FAQs
    Replies: 29
    Last Post: 03-08-2007, 10:38 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •