Results 1 to 4 of 4
  1. #1

    Intermittent Dash Problem & Limp Mode

    I have a 12F that has a dash problem. The ski runs fine when the dash is on. The dash periodically goes out and ski goes into limp mode. Any suggestions? Thanks
    Last edited by 2weelz; 09-05-2008 at 09:03 PM.

  2. #2

    Join Date
    Sep 2008
    if ski continues running when cluster is inop most likely in cluster

  3. #3
    Yes, it still runs when the gauges are inop but it puts it into limp mode. Gauges need replacing? Would like to get some facts before dropping big money on gauges, if you know what I mean. Thanks

  4. #4

    Join Date
    Sep 2008
    Never spend unnecessarily, for sure! That money can be used on go-fast after u straighten out the got-to's!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 6
    Last Post: 04-10-2012, 01:50 AM
  2. Fixed my limp mode problem and now runs great!
    By stubburnjdh in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-13-2011, 08:03 PM
  3. 2007 Challenger 180 Problem - Limp Mode
    By cmspeer in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 08-22-2008, 12:28 PM
  4. 03 Polaris MSX 140 Limp Mode Problem
    By sbquality in forum Polaris Open Discussion
    Replies: 3
    Last Post: 06-28-2007, 10:32 AM
  5. limp mode vs over of fuel
    By andy95'slx780 in forum Polaris PWC Performance
    Replies: 1
    Last Post: 10-02-2006, 04:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts