Results 1 to 4 of 4

Thread: 95 750 slt

  1. #1

    95 750 slt

    Craft won't turn over unless electric box is touching ground. (engine) All wires seem to be ok. When box touches engine, mfd is erratic. Ran great in early August. New battery. Please help.
    Thanks


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Howard Welcome to the Hulk!!!

    Check the main ground from the battery to the engine bed plate. Remove and sand the connection..

  3. #3
    Quote Originally Posted by beerdart View Post
    Howard Welcome to the Hulk!!!

    Check the main ground from the battery to the engine bed plate. Remove and sand the connection..
    Thanks. Do you know offhand where that connects ?

  4. #4
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Why yes I do!!!!

















    It is below the water/thermostat.. outlet. Follow the black wire from the battery..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 95 750 slt problem
    By Boostman21 in forum Polaris PWC Performance
    Replies: 4
    Last Post: 07-02-2011, 12:48 PM
  2. 93 polaris 750 SL engine swap to 95 750 SLT
    By g_magic_tsp in forum Polaris Projects
    Replies: 0
    Last Post: 06-05-2011, 09:38 PM
  3. 95 750 slt
    By dirtdude35 in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-20-2009, 08:42 AM
  4. WTB Carbs for a 95 750 slt
    By gorey in forum Polaris Classifieds
    Replies: 6
    Last Post: 07-15-2009, 03:51 PM
  5. help with a 95 750 slt
    By dv8rxp in forum Polaris PWC Performance
    Replies: 1
    Last Post: 06-25-2009, 11:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •