Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6

    1994 750 sl compression check

    I took all the plugs out, tested it cold. they were 127,130,127. any good?


  2. #2
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Welcome to the Hulk! Looks good. Now go ride it!

  3. #3
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Hey, lets see some pics of what you have there. Including under the hood. We love pics!

  4. #4
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6

    ok i will! lol nice day for it mich too. 76 sunny

    OK i will post a pic of it or two when im out there. I bought the 1994 polaris 750 sl and a double tandem trailer for 1000.00 motor has 104 hours on it and look ok.

  5. #5
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Thats cool.
    Enjoy the warm weather while ya can my man. Has the fuel system and carbs been gone through?

    You can down load the serv manual here... http://www.mattmans.com/polaris/upload
    Last edited by starflight; 09-06-2008 at 11:17 AM.

  6. #6
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6

    no gas at dock

    No gas at dock. couldnt run it. maybe tomm. does bog when ya punch it 80-100% throttle, and in turns it bogs a lil. any idea? I need to clean carbs, check diaphrams and lines, changed filter. plugs are good (8's) as is compression. idles fine, never stalls ,doesnt load up. just a tad of start fluid when ice cold or after sitting for like 45 mins. sounds like im getting air somewhere. The line wont stay primed maybe, not sure.
    Last edited by bowsniper; 09-06-2008 at 08:46 PM. Reason: adding stuff

  7. #7
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Does it have the 3 outlet fuel pump?

  8. #8
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    no i need one of those too . a mikinui right? still need to recalibrate pop off pressure and carb settings after that, need diagram for running the new lines i have no clue. maybe my racing buddy down the street does he has a 1995 polaris slt and a 94 sl like me. we both have the same skis he hasnt seen mine yet. he'll be like wow you have a 95 slt and a 94 sl like me?
    lol too funny huh/ my big one is blown ,,,,, bad piston.

  9. #9
    Lake Mead Bum & BTLS Mark starflight's Avatar
    Join Date
    May 2007
    Location
    Boulder City, NV
    Posts
    3,364
    +1
    1
    Check with john zigler (member here same nick) has the pumps for $35 (new). You say bad piston in your other boat. Is it a hole in the piston? Is it the mag (front) piston?

  10. #10
    bowsniper's Avatar
    Join Date
    Aug 2008
    Location
    macomb,michigan
    Posts
    5,896
    +1
    6
    ahhhh been so long ago i dont remember. i think it was the mag.1 looked fine, the other looked like someone beat it up with buckshot in it and the other had a dent in the center of it. or a hole i dont remember

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. yet another 1994 Polaris SL 750 jet ski project
    By Artiom in forum Polaris Projects
    Replies: 172
    Last Post: 09-05-2011, 08:56 PM
  2. 1994 750 Sl loss of power
    By T-Trubble in forum Polaris PWC Performance
    Replies: 2
    Last Post: 08-12-2011, 08:06 PM
  3. 1994 750 Sl loss of power
    By T-Trubble in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-09-2011, 01:37 PM
  4. 1994 750 sl reeds
    By scotty2hotty in forum Polaris Open Discussion
    Replies: 12
    Last Post: 03-09-2008, 12:09 AM
  5. 1994 Polaris SL 750 problem
    By Playtime in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-24-2007, 06:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •