Results 1 to 9 of 9
  1. #1

    this doesnt look right to me

    just got my new 08 RXP X and have about 7 break in hours on it. I was looking in to changing the oil and noticed the oil filter cap looks like it has a cut out in it with part of the O ring showing. oil level has been fine is it supossed to look like that?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	30%.JPG 
Views:	110 
Size:	62.4 KB 
ID:	92876  


  2. #2

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    Looks Fine And Is Normal.todd

  3. #3
    your not supposed to see the o-ring, the flat area on the cap is normal.
    looks like they squished the o-ring during install of the cap. There is more than one o-ring so no worries, you`ll fix it when you do the oil change.
    i would recommend having the necc o-rings and extra filters on hand when doing your service...

  4. #4

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    Looks Like Grease To Me,i Havenot Seen A Red O Ring. Did They Change Them From Black To Red?todd

  5. #5
    Ridin' the Rancocas 04RXP22's Avatar
    Join Date
    Aug 2007
    Location
    Mt. Laurel, NJ
    Posts
    2,722
    Quote Originally Posted by Turbo Todd View Post
    Looks Like Grease To Me,i Havenot Seen A Red O Ring. Did They Change Them From Black To Red?todd
    i sell orings... red is silicone and black is buna-nitrile

  6. #6
    PEST!'s Avatar
    Join Date
    Jun 2008
    Location
    Rockledge Florida
    Posts
    768
    Quote Originally Posted by Turbo Todd View Post
    Looks Like Grease To Me,i Havenot Seen A Red O Ring. Did They Change Them From Black To Red?todd
    Yea been using red ones all summer.. Havent had one fail yet . The flat spot is standard

  7. #7

    Join Date
    Apr 2005
    Location
    Jax,FL
    Posts
    2,677
    +1
    24
    I KNOW COMPANYS MAKE RED O RINGS I BUILD TRANSMISSION BUT DOES BRP USE THEM NOW?TODDIE

  8. #8
    Shogren65's Avatar
    Join Date
    Apr 2008
    Location
    Spencer, MA
    Posts
    88
    Just looked at mine yesterday looks the same. No leak so im not worried about it.

  9. #9

    Join Date
    Apr 2008
    Location
    Blaine,MN
    Posts
    72
    i have a 04 rxp and my onrings were black. i think the red is the high temperature silicone.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. This setup look right?
    By dmeyer07 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 06-22-2012, 09:59 AM
  2. Craiglsit ad, looks legit to me
    By upgraded in forum eBay Finds
    Replies: 3
    Last Post: 09-20-2011, 02:48 PM
  3. Does this look right to you?
    By mfear in forum Yamaha PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-17-2010, 08:44 PM
  4. Electrical issues... This hobby is getting to me!
    By PWCManiac in forum Yamaha PWC Performance (2-stroke)
    Replies: 16
    Last Post: 08-18-2009, 12:10 AM
  5. hmmm, this doesnt look good...crack in tunel RXTX
    By XTrider in forum 4-Tec Performance
    Replies: 25
    Last Post: 06-03-2009, 02:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •