Results 1 to 4 of 4
  1. #1

    900ZXI one click- no start

    when i try to start, it clicks once and that's it. I got a new battery. Does the starter need to be replaced? Any help would be great.

  2. #2

    Join Date
    Jul 2008
    Orange County, NY
    Could be the starter, could be a bad connection, could be the starter solenoid.

  3. #3
    seaobin's Avatar
    Join Date
    Jun 2007
    Raleigh, North Carolina, United States
    new batteries need to be charged. Check starter too, but I would charge the battery

  4. #4
    Could be the starter bendix is bad or maybe the motor is locked up. Pull the plugs and see if u can turn the motor by hand

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clicks when start button is pushed
    By leedanger in forum Kawasaki PWC Performance (4-stroke)
    Replies: 8
    Last Post: 09-12-2012, 10:09 AM
  2. Going great one day. No start the next
    By aj1987 in forum Polaris Open Discussion
    Replies: 14
    Last Post: 09-22-2010, 07:27 PM
  3. click click then start
    By busa504 in forum 4-Tec Performance
    Replies: 10
    Last Post: 02-13-2010, 09:42 PM
  4. Polaris '96 SLX780 clicks, doesn't start
    By scarrock in forum Polaris Open Discussion
    Replies: 9
    Last Post: 05-24-2007, 07:21 AM
  5. Clicking noise at fuse box and ski wonts start at times.
    By excess in forum 4-Tec Performance
    Replies: 8
    Last Post: 01-08-2007, 09:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts