Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1

    worth cavitation

    Stage 3 RXP


    Installed Gibson Exhaust
    Installed Riva Intake Grate
    Installed 50lb racing injectors


    Installed Pro SP-IMP-159- 15/19R
    Installed RIVA 'GEN-2' Power Cooler Kit

    Installed RIVA Pump Wedge

    Installed RIVA Pro-Series Sponson
    Installed Steel Wear Ring
    Installed Stock ECU (I have Riva ECU But waiting for Activation Code)
    Installed Blow Off Valve

    Installed R&D RXP C5 Monster Charger Wheel, Spacer, Front Housing
    Installed R&D RXP Anti-Cavitation Pump Cone Spacer .350 thick





    68 mph at 7800 to 7,850 rpm. (previous rpm were 8,050)
    previous speeds were 64 mph without mod

    And now I have bad cavitation betwen 3000 rpm and 5000 rpm

    anybody can help me with this!! thanks I'll appreciate
    Last edited by douglasb76; 09-08-2008 at 11:02 AM.


  2. #2
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    U doin 68 with all that done???? shold be more like 76. Is that what the ski speedo say or you got GPS?? as far at cavitation is your wear ring in good condition?? Also how is your carbon ring?? Your revs are low think maybe you need to take some pitch out of your prop but i think that some thing is not right with your setup.
    Last edited by R88ory RXP; 09-08-2008 at 09:17 AM.

  3. #3
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by R88ory RXP View Post
    U doin 68 with all that done???? shold be more like 76. Is that what the ski speedo say or you got GPS?? as far at cavitation is your wear ring in good condition?? Also how is your carbon ring?? Your revs are low think maybe you need to take some pitch out of your prop but i think that some thing is not right with your setup.
    +1 Definately something wrong there!!!! they are just about stock figures.. What is your RAD?

  4. #4
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Also are you running the Riva ECU?? and the valve train upgrade?? if you are not running the riva ecu then you got the wrong injectors.

  5. #5
    AKA: Larry lafjax's Avatar
    Join Date
    Jul 2006
    Location
    Jacksonville, Fl
    Posts
    3,032
    I agree too! 68 is not fast enough with those mods. Are you sure you are not loosing some boost??

  6. #6
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Welcome to Greenhulk!!!!!

    Doug..I would start by taking out that Pump spacer cone..Thats robing you of RPM and speed...

  7. #7
    HORSEPOWER JUNKIE 9secZO6's Avatar
    Join Date
    Jun 2007
    Location
    Belle Chasse, La.
    Posts
    2,006
    +1
    1
    50# inj. + stock ecu = pig rich and no speed. Some 42s and a rrfpr would be in order if no race ecu/valvetrain upgrade

  8. #8
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by 9secZO6 View Post
    50# inj. + stock ecu = pig rich and no speed. Some 42s and a rrfpr would be in order if no race ecu/valvetrain upgrade
    100% agreed, but he has'nt said exactly what he has and has'nt got so it is difficult to know. The 50s aint no good with out the manegment to control them. R88

  9. #9
    R88 may you right because I didn't put my riva ECU yet cause I'm waiting for the activation code!! I will retest this weekend but I would like to fix the cavitaion problem first


    I forget to say that I replaced the Wear Ring I put Steel Wear Ring
    and I'm thinking that's the problem because,I see this ring little big and it's not seating right

    Also I have a blowoff valve and I can hear that it's losing pressure at high rpm


    Any suggestion are welcome thanksssss

  10. #10
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Get the ecu in first and then see what she does.....Those 50s are to big for the stock ECU.....

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does is worth to buy the R&D Anti-Cavitation cone?
    By mike1706 in forum Yamaha PWC Performance (4-stroke)
    Replies: 40
    Last Post: 06-15-2012, 10:06 PM
  2. Prop boot and cavitation
    By Jeff C in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 01-28-2011, 08:09 PM
  3. Is it worth going from Normal OPAS block off to Pro OPAS ?
    By rxp_boy in forum 4-Tec Performance
    Replies: 12
    Last Post: 11-01-2005, 09:18 PM
  4. Cavitation issue: worried
    By BDNJ in forum 4-Tec Performance
    Replies: 62
    Last Post: 09-13-2005, 08:21 AM
  5. Post on cavitation
    By Kinchyle in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 08-04-2005, 10:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •