Results 1 to 5 of 5
  1. #1
    soccerkikr
    Join Date
    Sep 2008
    Location
    Washington State
    Posts
    21

    rock in my prop?

    First of all I wouldl like to thank this forum. I have recieved help that has saved me hours of searching for anwsers. You guys are great!!!!

    I have a 93 Polaris SL750 and I tried to start it in to shallow of water and I think I may have gotten a rock in it. When I push the start button all I get is a loud click and it sounds like something is stopping it from turning over.

    what do I do???

    Thanks
    Soccerkikr


  2. #2
    hi well first off i dont know all that much about these things as i am a beginer.

    i have read alot of posts and may have an idea...

    have u looked under in the intake to see if there was any sort of blockage?

    and it may be a sylinoid problem, but wait for other replies to learn more about that cuz i have never had a problem with that.

  3. #3
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Remove the sparkplugs and engine coupler cover.

    Turn the engine over by hand . If it won't turn you may have something in the pump, the bendix may have failed, or the engine seized.

    Put her on the trailer and have a look at the intake area of the jet pump.

  4. #4

    Smile

    Quote Originally Posted by soccerkikr View Post
    First of all I wouldl like to thank this forum. I have recieved help that has saved me hours of searching for anwsers. You guys are great!!!!

    I have a 93 Polaris SL750 and I tried to start it in to shallow of water and I think I may have gotten a rock in it. When I push the start button all I get is a loud click and it sounds like something is stopping it from turning over.

    what do I do???

    Thanks
    Soccerkikr
    Did you start it ??you said tried to start in shallow water ,its hard for a rock to get sucked into pump trying to start it.Its possible I guess but highly unlikely.I would look at pulling spark plugs,see if engine turns over,check in pump for rocks, if engine wont turn over remove pump (5 minute job) then see if engine turns over,it could be anything from a stuck pump to a seized engine, or simply a bad starter or relay.>Marvin

  5. #5
    la90043's Avatar
    Join Date
    Oct 2006
    Location
    Los Angeles
    Posts
    1,201
    That mistake is gonna cost you...............................


    Quote Originally Posted by soccerkikr View Post
    First of all I wouldl like to thank this forum. I have recieved help that has saved me hours of searching for anwsers. You guys are great!!!!

    I have a 93 Polaris SL750 and I tried to start it in to shallow of water and I think I may have gotten a rock in it. When I push the start button all I get is a loud click and it sounds like something is stopping it from turning over.

    what do I do???

    Thanks
    Soccerkikr

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Are there rocks in my pump?
    By Mike Greenwood in forum MSX/Matrix
    Replies: 19
    Last Post: 07-04-2015, 07:16 AM
  2. my prop got in a fight with a rock,,guess who one!
    By usamps in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-20-2013, 03:00 PM
  3. What prop should I have in my ski
    By bruinsrme in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-05-2008, 08:35 PM
  4. Replies: 4
    Last Post: 06-18-2007, 10:18 AM
  5. Finally tested a tweaked 15/20R prop in my ski
    By GPR/STX-15F/RXT in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-16-2006, 10:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •