Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    RXP Spinning up!

    Guys, need some help! I am getting bad spinning out of the gate and the ski hits the limiter for a few seconds before hooking up and going.

    I am running a 14/19 with a stainless liner and a few other mods to the ski like a blade, Rotax ECU, intercooler, shortened waterbox and rear exit exhaust.

    Any ideas how i can get it hooked up?


  2. #2
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by 100% View Post
    Guys, need some help! I am getting bad spinning out of the gate and the ski hits the limiter for a few seconds before hooking up and going.

    I am running a 14/19 with a stainless liner and a few other mods to the ski like a blade, Rotax ECU, intercooler, shortened waterbox and rear exit exhaust.

    Any ideas how i can get it hooked up?
    How long have you been running the 14/19 with the SS wear ring? The SS wear ring wears your prop over time.. I'd recommend two things: 1st- send your prop back to solas to have it re-worked~~I think they charge around 70 bucks or so~~ 2nd- you can replace your OEM carbon boot for a aftermarket driveshaft seal.
    These two thing will help your holeshot a ton!!!!

  3. #3
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by 100% View Post
    Guys, need some help! I am getting bad spinning out of the gate and the ski hits the limiter for a few seconds before hooking up and going.

    I am running a 14/19 with a stainless liner and a few other mods to the ski like a blade, Rotax ECU, intercooler, shortened waterbox and rear exit exhaust.

    Any ideas how i can get it hooked up?


    WOW, 2 years on the boards and JUST NOW making a post...its about time! J/K


    UM, a 14/19 and those mods...You need a WAY bigger prop. 15/20 is more like it...You got too much power for that little prop.


    Can you list EVERY MOD you have, to make sure you have everything just right?

  4. #4
    I AM A VERMIN icerat4's Avatar
    Join Date
    Jan 2007
    Location
    CRYSTAL LAKE IL
    Posts
    5,098
    Quote Originally Posted by Danny View Post
    WOW, 2 years on the boards and JUST NOW making a post...its about time! J/K


    UM, a 14/19 and those mods...You need a WAY bigger prop. 15/20 is more like it...You got too much power for that little prop.


    Can you list EVERY MOD you have, to make sure you have everything just right?



    Danny thats because he Was 100% NOW HE IS 99%

  5. #5
    Fast & Loud meeper's Avatar
    Join Date
    Jul 2005
    Location
    West Grove, PA
    Posts
    5,019
    +1
    54
    still sounds like cavitation to me, if it was the wrong prop and wear ring clearance was good he would just be hitting the limiter...

  6. #6
    Banned User
    Join Date
    Sep 2007
    Location
    USA
    Posts
    22
    I would check the carbon seal or the bellows. Bet it's one or the other.

  7. #7
    Moderator RX951's Avatar
    Join Date
    Apr 2005
    Location
    League City, Texas
    Posts
    16,066
    +1
    23
    welcome to posting

  8. #8
    Yea yea, I know I took my time to post!

    Thanks for the advice guys. The stainless liner is all good and the prop is new so cant see that being an issue. May try the boot and a larger prop then.

    Re the mods Danny, all I have is a Rotax ECU, supercharger blade, straight through exhaust, shortened water box, open loop cooling, OPAS block off, stock lowered sponsons

  9. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Quote Originally Posted by 100% View Post
    Yea yea, I know I took my time to post!

    Thanks for the advice guys. The stainless liner is all good and the prop is new so cant see that being an issue. May try the boot and a larger prop then.

    Re the mods Danny, all I have is a Rotax ECU, supercharger blade, straight through exhaust, shortened water box, open loop cooling, OPAS block off, stock lowered sponsons

    But you also listed an external IC, right? So you got all the items to have a Stage 3 setup (ECU, Wheel, IC), you just have too much power for that prop....

  10. #10

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP locked up first time out
    By XSV in forum Sea Doo Open Discussion
    Replies: 36
    Last Post: 05-17-2008, 02:23 PM
  2. 9 Hr RXP Acting Up anybody got an ideas???
    By excess in forum 4-Tec Performance
    Replies: 9
    Last Post: 01-17-2008, 08:47 PM
  3. 2004 Rxp Blew Up ??
    By RXP19 in forum 4-Tec Performance
    Replies: 40
    Last Post: 01-14-2008, 08:53 PM
  4. RXP breaking up under boost
    By blackvr in forum 4-Tec Performance
    Replies: 22
    Last Post: 05-28-2007, 09:05 AM
  5. rxp waken up
    By yellow jacket in forum 4-Tec Performance
    Replies: 15
    Last Post: 05-20-2007, 06:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •