Results 1 to 2 of 2
  1. #1
    Dajnglst dajnglst's Avatar
    Join Date
    May 2008
    Charleston SC
    1999 FICHT Polaris Genesis 1050
    Repaired ignition signal, but boat does not rev out.

    Starts and runs but will not rev above 3,400 RPM regardless of throttle position.

    TPS ?
    Air temp sensor ?
    Air Pressure sensor ?
    Fuel Pressure ?
    Limp Mode from temp sensor ?

    Any service info on line for ficht to perform simple sensor tests to isolate it?

    Anyone know if there is a special plug or adapter needed to read codes from emm on polaris if using evinrude Ficht software ?

    Have an outboard shop here in town with FICHT software but can not seem to plug it up to the Polaris.....

    Any clues ?

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    Welcome to the Hulk.

    Are any warning lights or messages on the MFI display?

    Are all three cylinders firing, and getting warm?

    What was repaired?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Need Ignition Update Kit/Repair Suggestion for 1998 SLTH 700
    By seipper in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-18-2013, 05:51 PM
  2. Gel coat repair?
    By sprchrgd89gt in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-29-2013, 06:05 PM
  3. Any one repair igniter boxes ?
    By in forum Polaris Open Discussion
    Replies: 1
    Last Post: 10-23-2008, 03:11 PM
  4. Warranty repair?
    By Pee2xUSee in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-18-2005, 04:29 PM
  5. Hull Repair
    By Red Devil in forum 4-Tec Performance
    Replies: 4
    Last Post: 06-29-2005, 03:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts