Page 1 of 14 1 2 3 11 ... LastLast
Results 1 to 10 of 136
  1. #1
    Powertek powertek's Avatar
    Join Date
    Jan 2008
    Location
    Toronto,Ontario
    Posts
    350

    RXP X rings...shot to hell!

    Wondering where my performance and boost was going....well I found the problem. My X has only 20 hours on it. The worst rings I have ever seen!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	x rings 002.JPG 
Views:	124 
Size:	2.04 MB 
ID:	93703   Click image for larger version. 

Name:	x rings 004.JPG 
Views:	80 
Size:	1.87 MB 
ID:	93704   Click image for larger version. 

Name:	x rings 007.JPG 
Views:	95 
Size:	1.72 MB 
ID:	93705   Click image for larger version. 

Name:	x rings 008.JPG 
Views:	99 
Size:	1.93 MB 
ID:	93706  


  2. #2
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Are you not going to have that fixed under warranty

  3. #3
    Powertek powertek's Avatar
    Join Date
    Jan 2008
    Location
    Toronto,Ontario
    Posts
    350
    Yes....its getting fixed under warranty right now. The boat will be ready on Friday. I have heard this has happend to a few x boats!!

  4. #4
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by powertek View Post
    Yes....its getting fixed under warranty right now. The boat will be ready on Friday. I have heard this has happend to a few x boats!!
    Yeah... Id say .135 end gap is a bit loose

  5. #5
    Powertek powertek's Avatar
    Join Date
    Jan 2008
    Location
    Toronto,Ontario
    Posts
    350
    I would say too...big end gap! Wondering where all my performance was going! Well I finally found the problem!

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    What was your compression before tear down???

  7. #7
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    what have they said caused it water? lack of oil? dirt? overheated? something has caused excessive and premature wear. I just pulled apart a turbo rxp motor with 25-30 hrs on it and the pistons are mint except the one that had a valve drop onto it DOH! but as far as wear goes its mint.

  8. #8

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    I'VE BEEN TELLING Y........ Can you say race gas boy's and girls. 100 PLUS octane.
    Last edited by jawz; 09-10-2008 at 03:44 PM.

  9. #9
    Banned User
    Join Date
    Jul 2006
    Location
    Ft.Lauderdale
    Posts
    3,237
    Quote Originally Posted by jawz View Post
    I'VE BEEN TELLING YOU GUY'S THIS FOR MONTHS NOW! TOO MUCH boost ruined your motor! I talked to Jerry about this last week! It is NOT S-D's fault!
    Your joking right? He's only running around 13 pounds of boost..Many people including myself are running more than that with no problems..

  10. #10

    Join Date
    Jan 2006
    Location
    Rydal, Georgia U S A
    Posts
    3,936
    +1
    14
    Quote Originally Posted by Alex13 View Post
    Your joking right? He's only running around 13 pounds of boost..Many people including myself are running more than that with no problems..
    Not on an X!

Page 1 of 14 1 2 3 11 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Are the RXPX wear rings going to have the same issue as the RXP?
    By bustercherry in forum 4-Tec Performance
    Replies: 13
    Last Post: 01-31-2008, 03:59 PM
  2. Those Going to MUDBUG:: In Need of RXP Wear Ring.....!!!!!
    By VFX_Artist in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-07-2006, 07:40 PM
  3. RXP 79.2mph, mods to get me there!!
    By seadoo02xp in forum 4-Tec Performance
    Replies: 45
    Last Post: 07-12-2005, 10:00 PM
  4. What would cause the hole shot to decrease?
    By Ed in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 06-30-2005, 05:46 PM
  5. Got my IR Plugs for my RXP. Do I have to wait?
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-21-2005, 11:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •