Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Aug 2008
    Location
    Western Maryland
    Posts
    50

    99 ultra 150 speed confusion ??

    Finally used a gps on my 99 ultra150, and got 68.4mph. This can't be right ? I know the stock carbs are modded a little bit, I didn't think it would go that fast. R&D sponsons, nozzle, extended rideplate, solas dynafly impeller, inland jetsports waterbox. I tried it numerous times and then my buddy who weighs about 30lbs heavier than I am got 67.7mph, he weighs 205lbs. Now I'm thinking to get a shredmaster rideplate will it give me more ?? We are gonna try this gps run again this weekend, and see if there was a glitch, cause its hard for me to believe, are they that accurate ?


  2. #2
    Wankel till I die!! jonjonwells's Avatar
    Join Date
    Apr 2007
    Location
    SE Kansas
    Posts
    637
    That is about right. Some of them are faster then others. High comp heads really only give better accel not top end. A shredmaster will help you in the chop for sure.

  3. #3
    Yeah, have you done a compression test. I'll bet its atleast 130 lbs if not more. Like he said compression only adds torque so its not like you have to have it to run fast. 68 isn't out of the ordinary for a modded Ultra

  4. #4
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    That is very possible its rite with the mods you have.

  5. #5

    Join Date
    Aug 2008
    Location
    Western Maryland
    Posts
    50
    Compression is 140 in each cylinder. Took it out tonight and I'm running 90:1 premix in the gas also and plugs are getting a little fouled so I Didn't have the R6918C-9 plugs but had a set of brand new iridium br9eix plugs from my sled, and installed them, did two passes on glass water and now it ran 69.2mph on gps !! Why in the world would it run faster with the non-recommened plugs ? I did two passes and brought it out in fear of burning it. but plugs looked fine. Can I run those plugs, or should I go get the $15 plugs ? Believe me I'm not complaining bout the speed, just confused why it ran faster.

  6. #6
    You've got what amounts to a level 1/stage 1 set-up. I imagine you either have aftermarket heads or some one has shaved the stock heads down because usually stock around 120psi. If you have a/m heads you can run the other plugs.

  7. #7
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    If you are running aftermarket heads or it is a later production 99 then those plugs are fine. You can probably go search the archives on the ultra 150 site and find out what Hin need the expensive plugs.

    Nice #s btw

  8. #8

    Join Date
    Aug 2008
    Location
    Western Maryland
    Posts
    50
    Whats the website to find out if my ski needs the plugs ?? Yeah its stock heads so Idk, but I had people standing along the shoreline to see me run down the river, spotlight for 2 passes lol, but anyway I will get my vin # now.

  9. #9

    Join Date
    Aug 2008
    Location
    Western Maryland
    Posts
    50
    Nevermind I found it ! Hin 41804 and after was the ignition you could run the regular sparkplugs BR9ES, NGK. For example mine is Hin 41189, and requires the R6918C-9 Plug. This is good info for people that have the 1999 model. From what I read if you run the expensive plug in the newer ultras it gives you the same performance, as the 1999 model had. So with that in mind wonder if the guys with the 2000 and on ultras added those plugs, you would see a performance gain ???? The dealership told me there was no difference in the plugs, but NGK, said no, there is a huge difference in the two, some material I forget now what I read its called but, definitly more precisely made evidently. I'm buying a new set tomorrow in fact.

  10. #10
    btldigger's Avatar
    Join Date
    Feb 2007
    Location
    lebanon tn.
    Posts
    1,641
    It doesnt work that way it wasnt the plugs it was the ignition mapping. The early ones had problems cracking plugs from what I have read so thats why they used the expensive plugs. If you change heads then the plug is at a different angle so it doesnt have that problem.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Best New High Speed Run On My 99 Ultra 150
    By Hybrid AWD in forum Kawasaki Open Discussion
    Replies: 16
    Last Post: 07-22-2009, 08:24 AM
  2. 99 Ultra 150 won't start
    By wareameye in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 09-24-2007, 06:48 AM
  3. Ultra 150 Speed
    By icedog10 in forum Kawasaki Open Discussion
    Replies: 2
    Last Post: 09-08-2007, 01:04 AM
  4. 99 Ultra 150 Pump bearing replacement
    By gilson in forum Kawasaki PWC Performance (2-stroke)
    Replies: 5
    Last Post: 05-09-2007, 01:59 PM
  5. 99 Ultra 150 an weird problems
    By xplayer2885 in forum Kawasaki How To & FAQs
    Replies: 8
    Last Post: 09-21-2006, 03:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •