Results 1 to 9 of 9
  1. #1

    Unhappy Horrible noise while flushing

    Hi 2nd day with my new seadoo, aldready probs
    So I started the engine, put the water one and after one minute or so. I did pull the gas very briefly because it says so in the manual.. The engine begins,, shortly after doing that,,, to make horrible noise. So I turned off the water and shut down the engine. It smelled a little and i slight smoke came out of the rear...
    So what the f*** did I do to my engine?! Do you guys think I should already get a mechanic after 2 hrs of usage??


  2. #2
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Quote Originally Posted by knave View Post
    Hi 2nd day with my new seadoo, aldready probs
    So I started the engine, put the water one and after one minute or so. I did pull the gas very briefly because it says so in the manual.. The engine begins,, shortly after doing that,,, to make horrible noise. So I turned off the water and shut down the engine. It smelled a little and i slight smoke came out of the rear...
    So what the f*** did I do to my engine?! Do you guys think I should already get a mechanic after 2 hrs of usage??
    Welcome to the forum.
    need more info.
    what kind of noise
    it should have some smoke out the back and will smell.

  3. #3
    it was horrifying loud and creaked a little. Did it overheat maybe?? Sorry I can't really describe, i was so shocked that a ran to the water hose immediately , turned of the water, then the engine and almost fell into the water

    What I should maybe mention...what could have also done some damage to the engine... the jetski dropped today,,, with me on it and the jetski lift into the water because the cable broke... we were maybe 1 feet over the water...
    Last edited by knave; 09-12-2008 at 08:18 PM. Reason: another cause could be..

  4. #4
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    depends on wether it was the engine or jetunit making noise as the jetunits make some horrific noises out of the water.
    it wont overheat unless ran for quite some time without the hose on.
    put it in the water and test ride if it still makes noises take it to the shop.

  5. #5

    Join Date
    Jul 2008
    Location
    Stratford,Ct
    Posts
    960
    Out of the water mine makes a horrible rattling noise while running it with a hose,I was told that is normal.
    I don not hear anything where its in the water.

    Scared me he first time.

  6. #6
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Classic sea-doo prop noise

  7. #7

    Join Date
    Jul 2008
    Location
    Stratford,Ct
    Posts
    960
    Quote Originally Posted by bigdaddyRXP View Post
    Classic sea-doo prop noise
    Big power makes noise when out of water,Really you ski is screaming for you to go ride it again!

  8. #8
    R88ory RXP's Avatar
    Join Date
    Feb 2008
    Location
    Kent, England
    Posts
    2,737
    +1
    46
    Quote Originally Posted by Otto J View Post
    Big power makes noise when out of water,Really you ski is screaming for you to go ride it again!
    LMFAO that was a funny 1. R88

  9. #9
    monaroman76's Avatar
    Join Date
    Mar 2008
    Location
    Whyalla, South Australia
    Posts
    1,979
    +1
    28
    Quote Originally Posted by knave View Post
    Hi 2nd day with my new seadoo, aldready probs
    So I started the engine, put the water one and after one minute or so. I did pull the gas very briefly because it says so in the manual.. The engine begins,, shortly after doing that,,, to make horrible noise. So I turned off the water and shut down the engine. It smelled a little and i slight smoke came out of the rear...
    So what the f*** did I do to my engine?! Do you guys think I should already get a mechanic after 2 hrs of usage??
    Can you post a video?? sounds like it could just be the prop noise though.. It is a very disturbing rattling sound.. However it would make this noise as soon as you fired it up out of the water, there would be no delay after starting it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VX 110 Overheat alarm while flushing (Please Help)
    By Mark985 in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 03-03-2016, 05:11 PM
  2. Steam while flushing
    By Blown284 in forum Yamaha PWC Performance (4-stroke)
    Replies: 2
    Last Post: 09-27-2014, 02:10 PM
  3. Possible water in Engine while flushing (RXT-215)
    By FstSD in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 08-19-2013, 05:31 PM
  4. Diagnostic help..clacking noise while cranking
    By leedanger in forum 4-Tec Performance
    Replies: 2
    Last Post: 10-06-2012, 08:47 PM
  5. Wired noise while airborne Please help
    By sebas54 in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 05-10-2010, 03:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •