Results 1 to 6 of 6

Thread: piston trouble

  1. #1

    piston trouble

    I am installing a new piston in my sl750 and having trouble compressing the springs to put it back into the cylinder. any tips?


  2. #2
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,930
    +1
    1,407
    Make sure you have them installed in the correct direction and that the pin is lined up with the gap.

  3. #3
    yea they are installed correctly. it is cylinder 1 so its hard to get my hands in there to compress the rings

  4. #4
    rotate the crank so the one your working on is at the top of it's stroke

  5. #5
    finished it this morning. thanks a lot! runs great.

  6. #6
    She likes the bike. But the ski gets her wet!!!! xlint89's Avatar
    Join Date
    Oct 2006
    Location
    Cleveland OH
    Posts
    17,330
    +1
    31
    Did you find the cause of the piston failure?

    If not, it will happen all over again...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tip: Trouble codes for 4 Tec's
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 73
    Last Post: 06-02-2017, 07:34 PM
  2. Is .4 thou piston ring clearance asking for trouble?
    By rami_13b in forum 4-Tec Performance
    Replies: 42
    Last Post: 03-22-2013, 12:02 AM
  3. Trouble with number one piston!!!! Please help
    By Meversole6 in forum Yamaha PWC Performance (2-stroke)
    Replies: 33
    Last Post: 07-26-2012, 12:32 PM
  4. piston trouble on msx150
    By Joe dana in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-30-2007, 11:59 AM
  5. Impeller Shaft Trouble
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-06-2005, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •