Results 1 to 2 of 2
  1. #1

    My RXP is broke!

    Hi folks!

    So, I finally let my daughter ride my RXP. Big mistake! To make a long story short, she makes a wrong turn on the river and ends up in some thick swampy crap. After about an hour of trying to pull her out, I tow her about 10 miles back to the car and head home. I pull out tons of weeds and muck and check everything and it seems clear. I take it back to the water and it starts fine and moves at idle speed fine, but when I try to apply throttle, it revs up fine, but does not move. What has she done?!?!?!


  2. #2
    BertInTexas's Avatar
    Join Date
    May 2005
    Location
    Central Texas
    Posts
    377

    It's cavitating Ed

    You need to check the wear ring,impeller,and impeller shaft for damage.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. My RXP is faster than a triple piped STXr
    By LiquidDI in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 05-07-2013, 12:47 AM
  2. my 04 rxp is screwed for the bug
    By buddydoo in forum 4-Tec Performance
    Replies: 39
    Last Post: 06-05-2007, 10:51 PM
  3. What is this on my RXP?
    By vidbuster in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 05-11-2007, 09:44 PM
  4. found out what my rxp is running with the intake grate
    By kenshin89 in forum 4-Tec Performance
    Replies: 11
    Last Post: 03-17-2007, 02:09 PM
  5. thinking of Selling my RXP. Wife is pregnant and due March
    By Water4fire in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 08-07-2005, 07:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •