Results 1 to 6 of 6
  1. #1
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116

    08 Tx Impeller Shaft Replacement

    FOUND OUT AFTER 2 IMPELLERS CAME OFF THE THREADS ON THE SHAFT ARE STRIPPED. jUST ORDERED A NEW ONE. DOES ANYONE KNOW IF THIS SHAFT IS PRESSED IN OR EVERYTHING WILL JUST PIECE BACK TOGETHER WHEN i GET THE NEW ONE??
    Last edited by STSPERFORMANCE; 09-14-2008 at 04:46 PM.


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Steve,
    I dont think they are pressed in but i could be wrong..I know the bearing is pressed in though..Ill check the manual and see what it says..

  3. #3
    King_Of_Fun's Avatar
    Join Date
    Jul 2007
    Location
    Catawba Island, Ohio
    Posts
    2,703
    Isn't your ski still under warranty? I'd get the dealer to fix it. I don't see anything in your sig. for them to void the warranty... Ron

  4. #4
    Steve STSPERFORMANCE's Avatar
    Join Date
    Dec 2007
    Location
    Cambridge, Ohio
    Posts
    2,701
    +1
    116
    Those Are The Guys That Did The First Impeller Switch And Obviously Did Not Do That Right. Rather Do It Myself.

  5. #5
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Steve this is what the manual says:

    Use impeller shaft pusher (P/N 529 035 955) To press out impeller shaft of pump housing.Bearing will come out with the impeller shaft..

    Hope this is what your looking for..

  6. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Steve, i was thinking that it had to be something with prop or shaft after talking to you.
    It is hard to believe that with only one prop removal and install that the threads got striped so soon. I think they must of done something wrong when changing the prop the first time. Probably when prop came off the first time it spun and striped the threads. I am surprise you didnt have trouble tightening the prop in pump this last time.
    Now that makes me wonder if it wasnt the driveshaft or prop that cracked the pump.

    You need to quit tearing stuff up.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS - Parts yamaha 155 impeller , shaft , pump , sbt replacable wear ring
    By quadracer22 in forum Yamaha Classifieds
    Replies: 0
    Last Post: 01-04-2013, 11:22 AM
  2. 1995 SL750 Impeller shaft bearing housing replacement
    By skigolfnut in forum Polaris Open Discussion
    Replies: 1
    Last Post: 07-06-2009, 09:47 AM
  3. Grease for impeller/ shaft
    By Kinchyle in forum 4-Tec Performance
    Replies: 3
    Last Post: 02-22-2006, 04:41 PM
  4. Can anyone help me with my impeller shaft and new prop?
    By ccassone in forum 2-Stroke Performance
    Replies: 0
    Last Post: 02-10-2006, 03:45 PM
  5. Impeller Shaft Trouble
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-06-2005, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •